Date picker on monthly budget issue

Hello! My Year-Month-Period drop-downs at the top of my monthly budget dashboard seem to be broken. The Year displays a month name, and the Month sometimes displays a month name, others times displays a string of numbers or a selection from the Period field, and the Period usually doesn’t match either of the above. I’m not sure what’s going on. Any one else experience this before?

Example of issue (it can display differently than this, though):

What values appear when you look at the dropdown lists for the cells? Do they make sense?

Sometimes? They change and then sometimes don’t give me the options I need (the wrong months for the year or vice versa). For example, I select 2019 from the Year drop-down. It thinks a moment, then changes the Year field to January, and enters a number string in the Month box. When I try to select a month, it displays either November and December, or just January. If I select one, it then changes the Year to either a year I didn’t select or a random month name (Jan, Dec, or Nov).

(I attempted to post screenshots of what I’m seeing but it’s only letting me post one per post).

My selection options seem to be mostly normal, if not always consistent or correct for the other options chosen in the drop-down. The Year drop down shows me 2019 and 2020, or sometimes just one or the other. Same with the Month–either only January, or December and November. These are inconsistent and somehow independent of what displays in the Year drop-down. (I would have expected January to show for a year selection of 2020 but that’s not the case.)

Period seems to always show 12/1/2019. I can’t click on it fast enough before everything else changes to see if it provides other options.

One example of what happens after I select an option (I selected 2019, not 2020):
Screen Shot 2019-12-30 at 5.49.24 PM

Thank you for your help!

Hi @abbyd,

I believe you’re using the Tiller Budget via the Tiller add-on, right? You have a rollover column on your Budget dashboard?

If so, try restoring the dashboard via the add-ons menu > Tiller > Budget > Restore Dashboard.


That worked! Thank so much!

However, now none of my actuals are calculating. I read another solution elsewhere on here that said to make sure the header row is “Category” for the transaction sheet, and I also checked elsewhere it displays, and they’re all correct. Not sure what else it could be.


Double check

Categories sheet has the word “Category” in the header row 1 (no quotes)
Transactions sheet has the word "Category in the header row 1
Transactions sheet has the word “Date” in the header row 1

Just checked, and all is correct/as you said it should be. Still no actual calculating.
Thank you for helping me look into this!