Empower/Prudential Merge Update

Hi

Empower has completed their purchase of Prudential Retirement services by merging Prudential accounts into Empower website. I had accounts at both. Now, my accounts are all messed up. When I log in to Empower, I can see all the accounts with the correct balance. When I press , the correct balances are shown on my dashboard. But the connection is still refreshing. After 3 or 4 minutes to finish refreshing, 2 out of 3 accounts show incorrect balances, with 1 showing a zero balance. I’ve deleted the accounts and tried to re-link them. Same result.

Help!

Jeremy

Your best bet here is most likely going to be to reach out to the official support via chat at the console at https://my.tillerhq.com/

I’m having a similar problem the past week or so with Empower. Showing zero balances on both tiller and my google sheet. But when I refresh Empower the pop up shows the correct balances.

I tried the tiller chat but the answer fixed nothing.

They may have to escalet the issue with their data aggregator Yodlee in order to reach a resolution which can sometimes take a little while.