Excel - Cannot login google account

I cannot sign in to my google account from within the Tiller excel file. I get the following message.

Couldn’t sign you in
This browser or app may not be secure.
Try using a different browser. If you’re already using a supported browser, you can refresh your screen and try again to sign in.

Is anyone else having this problem? Does anyone know how to fix it?


I started getting this error today. It worked fine YESTERDAY. What changed overnight? I posted this same issue on Google. If I get a solution there, I will let you know.

I have tried:

  • Allowing less secure connections
  • Enabling 2 factor authentication
  • Uninstall/Reinstalling Chrome
  • Excel is up to date (is an O365 subscription)

Here is the response I got from Warren about this issue:

Our team is investigating this issue with Excel and hope to have it resolved quickly. We’ll get back to you when we have an update.

Anecdotally, we’ve heard from at least one customer that the Excel add-in is working fine after rolling back the most recent Excel update, so that may be an option to consider in the interim.

Also, you might try the Excel Online version of the add-in by opening your workbook in Excel online (make sure it’s stored on OneDrive) and then open the add-in in the browser based version to see if you can sign in there.

Thanks for your patience.

Any update? I was super excited to try out the Excel version only to get stuck at this screen. Thanks!


Hey everyone, quick update on this.

It appears to be the combination of two things (which has made it a bit tricky to track down):

  1. recent updates to Office are installing a new version of the embedded web browser (WebView2, based on Chrome), and
  2. a change with Google’s security practices involving embedded browsers.

Anecdotally, it also only affects some types of Google accounts or is, perhaps, being rolled out incrementally. (I do not experience the issue on 3 of the 4 accounts I’ve tried.)

Incredibly, it’s not clear yet what we can/should do to actually get around the problem. It looks like it will ultimately need to be resolved at the Microsoft/Google level.

Until then, one possible mitigation might be to remove the new WebView2 from your system – though I don’t necessarily suggest doing so because I don’t know what else on a given user’s system requires it. But if someone’s willing to take the chance, you can go to Settings > Apps & features and look for Microsoft Edge WebView2 Runtime in the list and uninstall that. That at least seems to have worked for me.

I’ll keep people updated as I learn more.


Relevant links:


Quick follow up here -

The big picture hasn’t changed much, this is still an issue at the Microsoft/Google level that they will ultimately have to solve.

We are pursuing some options to hopefully unblock folks in the nearer term and will provide updates if/when those roll out.

Hopefully everyone here received an email from me, but our fix for this has been pushed as of today and you can find your next steps here: