Feedback & Bugs for Tiller Labs Add-on

@martha.rudkin,

Try restoring this sheet using the Tiller Labs add-on under Managed Solutions (you don’t need to archive - you can overwrite existing).

If that doesn’t work you may be missing some dependent sheet or column headers.

Heather

Hello, I am currently getting this error on the Tags Report page: =IF(O12,“This report is based on tags added to the ““Tags”” column in the Transactions sheet”,“The required ““Tags”” column is missing from the Transactions sheet. Use the Tiller Labs add-on to reinstall this sheet”). I would love help figuring out what is wrong.

Hi @mariaaithne,

It sounds like you just need to “restore” the Tags sheet via the Tiller Labs add-on under Managed Solutions. That should re-install the Tags column in the Transactions sheet.

If you already had a Tags column in Transacitons just make sure the header is there in row 1 for it, “Tags” - no quotes.

Heather

@heather,

I restored the sheet as you suggested and I am still seeing the same #Ref! errors. It looks like the sheet is dependent on the Categories and Transactions sheets, and it is working correctly for months Jan-Sept. It appears to be having trouble with columns AA-AC in my Categories sheet.

Here is what I am seeing in your hidden cells. You can see that Col R is not getting the corresponding Col letters for Oct-Dec.

1/1/2020 R Categories!R2:R Categories Column Letter Range
2/1/2020 S Categories!S2:S Category A Categories!A2:A
3/1/2020 T Categories!T2:T Group B Categories!B2:B
4/1/2020 U Categories!U2:U Type C Categories!C2:C
5/1/2020 V Categories!V2:V Hide From Reports E Categories!E2:E
6/1/2020 W Categories!W2:W Category Column Exists? TRUE
7/1/2020 X Categories!X2:X
8/1/2020 Y Categories!Y2:Y Transactions
9/1/2020 Z Categories!Z2:Z Date B Transactions!B2:B
10/1/2020 [ Categories![2:[ Category D Transactions!D2:D
11/1/2020 |Categories!\2:|Amount H Transactions!H2:H
12/1/2020 ] Categories!]2:] Year Earliest Transaction 2019
4/1/2020 Year Latest Transactions 2020
2/11/2020

Thanks for your response. There is a Tags column in the transaction sheet with the header as you have said it should be.

I restored the sheet and it seems to be working now! Thank you for your guidance!

I can see the problem: the formulas in Q2:Q13 aren’t up to the challenge of two-letter column names.

I just updated and republished the template. Could you upgrade it and let me know if the issue resolves?

Thanks,
Randy

P.S. Thanks for your patience on this.

@randy

All fixed! thank you so much.

Martha

1 Like

In the Tiller Quick Insights, the # of Transactions imported is off by 1. Looks like it is incorrectly linking to cell c3 instead of c2.

Great catch, @Misken. I just updated the master.
Thanks for reporting this.

Randy

image

I’m trying to update the Quick Insights sheet to the new version but the Tiller Labs add-on won’t let me click on “Manage Solutions”. I can click on everything else in that menu (“Add a Solution”, “About Solution”, etc.).

Please help!

Sorry about that. A recent change had a permissions issue. I think I just fixed it. Can you try again, @misken?

Randy

Works now! Thank you.

Super. Glad to hear it.

Hi,
I just did some updating and my Balances sheet doesn’t work anymore. I’m not sure exactly which update did it, but is there maybe a known bug that causes the balances sheet to not populate?

Sometimes if you update/restore a sheet that other sheets refer to, the “downstream” sheets need to be restored as well, @clomok. Try using the Tiller Labs add-on to restore the Balances sheet.

@heather @randy

Updating to add Randy - it’s been 3 weeks since I originally posted, added Heather last week, and I still see no response.

In comparing the Tiller Quick Insights Top 10 Descriptions by Frequency to Yearly Insights Top Expenses, I am seeing different “Totals” for a couple of my Descriptions.

I have the Quick Insights Transaction Analyzer set for all accounts for this year (2020).

I have the Yearly Insights sheet set for 2020 sorting categories by total.

The Yearly Insights Top Expenses correctly captures both charges and credits (returns) to a specific Description (payee).

The Quick Insights Top 10 Descriptions by Frequency appears to only capture charges to the same specific Description (payee).

If I sort my Transactions sheet by Description and count the number of entries for the 2 Descriptions reporting different totals, I can see that the Quick Insights sheet is not using all the transactions for the set time period. It is only using “charges”, making both the frequency count and the total inaccurate.

For instance, I went to “Store A” and spent $100 on clothing. I later returned $25 of that clothing to “Store A”. I have 2 transactions for “Store A” in my Transaction sheet. Quick Insights shows 1 “Store A” transaction for $100. Yearly Insights shows $75 for “Store A”. I believe that the Yearly Insights calculations are the correct ones.

Thanks for checking into this.

I updated my Quick Insights solution to 1.03 and the “Feeling Stuck? Review the Help tab below” link doesn’t work.

When I click on it, I get a message at the bottom of the screen stating: “Cannot open the link because the linked sheet is deleted”.

I just did a “Restore Sheet” and I’m getting the same error when trying to click the “Feeling Stuck?” link.

Ah, this is a good call out, @Scott.t. It might be that you started with the Foundation template before the Help sheet was available so now that you’ve restored you’re getting the latest version of Insights from the Foundation Template that references the help sheet.

You can access it here: https://docs.google.com/spreadsheets/d/1_Ei4-Hn3nCZFIwoRjFCGadzVRCLGZRQbSJCspRfl1aI/edit#gid=420179238

I’m not sure if this is what you were suggesting, but I:

  1. Opened the linked spreadsheet
  2. Right-clicked the “Help” tab across the bottom
  3. From the right-click menu I chose “Copy to” and selected “Existing Spreadsheet”.
  4. I then chose my Tiller budget spreadsheet.
  5. I verified that my Tiller budget spreadsheet has a Help tab, and I renamed the tab to just be “Help”.

I then tried going to the Insights tab and it still tells me the linked sheet is deleted. Do I need to update the url that link’s referring to to instead refer to my own help tab’s address?

If so, is that just what’s after the # in the URL when I click on my Help Tab?