Fidelity credit card transactions added as positive values

I got a message yesterday that the Fidelity Rewards Visa card could now be added for my Fidelity account, but after adding it the spending transactions were imported as positive dollar amounts, instead of negative. Has anyone else experienced this?


I came here to report the same problem. When I went to take care of duplicate transactions from the previous standalone Fidelity Visa account, a purchase previously reported as $-19.90 comes in as $19.90 now.


At least your getting something. My old Fidelity Visa connection doesn’t work any more, and my new one (direct through Fidelity instead of scraping the Fidelity Visa site) isn’t updating at all. When I log into Fidelity directly, I see new transactions, but they’re not getting downloaded to my Tiller sheet. Also, the balance isn’t updating.

Came here to post exactly this. +1

+1 - need help on this

I have the same issue, the new connection just doesn’t seem to be loading anything.

+1 My Fidelity card charges have been positive values since they were moved to the open banking connection’, too.

1 Like

I had a similar issue initially. It was caused by my using a different logon id for the old connection site. I changed my id and password on the old site to match what I use on the Fidelity site. The open banking connection worked immediately after that. (Although the charges are coming in a positive values.)

Just replying to say, other than the +/- incorrect sign problem, my Fidelity credit card transactions seem to be feeding just fine. Tiller received a bunch the first day, and more yesterday.

Anyone not getting them make sure you’ve enabled the new account feed in both the Tiller console and in your spreadsheet.

1 Like

So, it turns out that I had the wrong account enabled, and I started getting transactions after I fixed that. But, like everyone else, they have the sign wrong.

1 Like

I made the same mistake with the wrong account since it’s listed twice on my fidelity accounts list now. Turned on the right one and got data, also with the signs inverted as others have said.

1 Like

Same here. Trying to figure out how to fix the +/- incorrect sign issue now.

1 Like

I tried to raise the +/- issue with Tiller. I don’t think I got through.

Just receive this reply from Twalane at Tiller:

Our data provider is currently working to fix a widespread outage affecting Fidelity Investments. They indicate the tentative ETA for the fix is 4/29.

In our experience, these ETAs can continue getting pushed back so our best recommendation is to manually track this account until it’s working properly. I’ve included a guide below with options.
You can check in on the status of this issue, and whether the ETA is being extended, on this dashboard: https: // / institution-outages.

Usually, we’ll see the revised ETA date published within a few days if the original ETA is missed. Any updates we receive will be posted as soon as we have news. I’m sorry about the temporary inconvenience.

If the connection still isn’t working a few days after the ETA passes, please reach out so we can continue troubleshooting. In most cases that won’t be necessary and you’ll find the connection working again once the outage resolves.

I believe you’ll now have the resources you need so I’ll close this conversation for the time being. Please feel free to reply here anytime if you have more questions about this outage.

If you need help with a separate issue, please start a new chat using the blue chat widget in the lower right corner of your [Tiller Console].


Same issue here with transactions coming in positive (+) instead of negative (-) after the Fidelity Visa Credit card feed update earlier this week.

We’re working with our data provider on this issue. Since there isn’t a way to continue using the old connection anymore, you can either manually clean up the polarity of the transaction amounts in your Transactions sheet (change the positives to negatives and negatives to positives) or just manually remove those transactions and unlink that card from the spreadsheet until this is resolved.

If we unlink and remove, when we relink, how far back will it pull transactions? Will it pull everything?

Also, @morgan, do y’all also know/see that the Fidelity Investments connection for the rewards credit card is pulling duplicate transactions?

I just linked a new GS to my data and only pulled in transactions from my CC from Fidelity. It pulled 109 transactions and 44 of them are duplicates.

We haven’t heard other reports of that but generally when there’s a site-wide outage, this can cause duplicates too.

Sorry if I missed something in this thread, but I can’t tell if I should continue to wait for the old direct connection to Elan to potentially be fixed, or if that connection is now dead forever and I need to go back to trying to get Fidelity Rewards card transactions from the Fidelity connection, which is how it worked at some point in the past?

I did not get any sort of a notification as described in the first message of this thread, my connection to Elan just stopped working.

Any guidance would be very much appreciated. Last time, when the connection to the Fidelity Rewards card disappeared in the core Fidelity connection, it was a pain to get it all cleaned up and connected to Elan. I just don’t want to go through that again until I know I have to. Also, if all the values from that connection are coming through with +/- swapped, I’m not too excited about that either.