Libro Credit Union Canada - cannot add account due to request timeout error

Hey there, I cannot add Libro Credit Union to my accounts. I have tried a number of times, but it is not adding to my list of accounts in the account summary section of my console. It stays in the “retrieving security information” for a few minutes, and then states it had a “timeout request error”. I cannot use the troubleshooting technique that refreshes or reconnects the account through new credentials, as the information requires the account to be listed to refresh the connection. Any help is appreciated! Thank you.

:wave: @burgesscapital,

Can you please try this workaround?

  1. Go through the Add Accounts process on the Console (
  2. When it gets to the “gathering details or security info” step, click outside the window (which will close it).

See if the account appears in your account summary after a few minutes.

Hey @heather ! Thanks for your reply!

As soon as I select Libro as the institution, add the credentials and click submit it goes straight into “Retrieving Security Information”. I clicked outside the screen at that point and waited, and nothing yet. I refreshed the console page and nothing there either.

@heather I have the same problem described above. Are any other tips available on how to connect to Libro CU? I tried the Feeds approach in the sheet, and the solution suggested above, and neither worked. I’ll do a manual import if I don’t hear back in a few days. Thanks for your help.