New Spending Trends Dashboard for Google Sheets and Microsoft Excel

I love this sheet. I had created a crude version of it myself, but without many options. It just showed spending in the last two months. This is great to have.

The only thing is it’d be awesome to have a pie chart in addition to the bar chart. For budgeting I just find pie charts way more useful to show me where most of my spending is going. Because it’s broken into categories along with subcategories it isn’t a simple matter of just creating my own pie chart based on the data.

I like the pie chart idea too. Our team was pretty torn on the chart type when we were building it. Thanks for this feedback and we’re glad you like it!

2 Likes

Or, if not a pie chart, and combining this request with what @Nic.Bab said, maybe just add the ability to sort the bar chart on the bar size. This would show the highest utilization in each category at top, instead of alphabetical sort.

1 Like

Thanks for the insight!

I’m curious - from your user research, what proportion of Tiller users emphasize monitoring expenditures vs. keeping a budget? My sense is that is a tension associated with an insights sheet. Some folks want a bit more granular info on their spending habits, while others want to emphasize spending in the context of their budgetary goals.

Great question @Nic.Bab, while I can’t share specific stats I can say that that when we ask users what their goal for using Tiller is budgeting and tracking are in the top 2 :slight_smile:

The Monthly and Yearly Budget sheets, which are still available and supported in the Foundation Template out of the box, are the resources for tracking progress against budget targets.

We’ve hidden them by default to reduce cognitive load for those just getting started with Tiller but they present nearly an identical view, except with the budget data available. The only potentially missing piece is a spark line that visually indicates how much of your actual represents what you’ve spent of your budget cap.

Spending Trends is the new solution for tracking spending when you’re not so interested in budgeting or just want a quick and streamlined view of where your spending is at in a certain time period without all the mental load of comparing against budgets.

I don’t closely follow budget but I do closely track my spending. I think it is common for people like me who “pre-budget” by automating their savings and required payments (mortgage, credit cards, some utilities). I know I have a certain amount I can safely spend each month.

However, even though I don’t closely follow a budget, I do make one a couple times a year as a form of financial review.

The Monthly Budget Calendar has been quite useful for me.

1 Like

I tried importing the spending trends dashboard into my existing Tiller sheet. It worked at first, but then when I selected a different time frame, all the data disappeared, and then it wouldn’t come back no matter which timeframe I selected from the dropdown. I’m getting a #REF error in cells AC2 and AQ2 (error message: “Array result was not expanded because it would overwrite data in AC101/AQ101”.

I contacted support via the chat button. Haven’t gotten to a resolution yet. Just posting here in case others run into similar issues.

So that just means that somehow something has gotten typed into those cells that are referenced. Go to those locations and delete the contents and it should fix your issue. That is for both cells AC101 and AQ101.

This is because those formulas will auto fill the cells below where they are located.

I didn’t type anything. But the spreadsheet itself is auto-populating empty check-boxes and getting in the way of itself somehow. I suspect there’s a “100” hard-coded somewhere in the backend, and that’s why the error is shows up in row 101.

For now, I seem to have gotten around the error by simply deleting some of the empty checkboxes that were present after row 100.

Continuing the discussion from New Spending Trends Dashboard for Google Sheets and Microsoft Excel:

I’m getting the same #REF! errors in AC2 and AQ2. When I reinstall Spending Trends, it shows “Hidden” in these cells along with the default populated data, but it errors when I change the date ranges - Same as you. I noticed that all cells (with checkboxes) from AC101 and AQ101 and later have “FALSE” in the formula bar. Very odd.

Hmm those accidentally auto populating like that sounds like a @randy question.

@stephenr I’d recommend reaching out to our support team via the chat window in the lower right corner of the Console at https://my.tillerhq.com/ - please just let the team know to pass to me per my note here in the Community.

FYI, that did not feel particularly intuitive, mainly because when you go to the ‘master’ spreadsheet you are greeted with the Instructions tab with lots of big, bold steps. One’s natural instinct is to begin doing those steps, when in fact you need to completely skip those steps if you already have a Foundation Template up and running.
Step 3 says “don’t request access” but I saw no option to do that.
Step 4 gives the correct instructions for copying the sheet over
However - in-between those steps there really needs to be a step that simply states "If you already have the Foundation Template installed, competely ignore the tab with all the instructions!
I mean, in the end, I figured it out and I guess most people probably will as well, but a bit of clarification here might prevent some extra support requests…

Thanks for your feedback here @dixonge

1 Like

I’m noticing that at a certain point (Row 100 to be precise), the spark line scales are considerably off. They seem perfect from Row 100 up, but at Row 100 and down it really falls apart and does so until the last Category (Row 138 for me). The amount values are accurate, the corresponding spark lines are not.

Update: It looks like this issue is happening in the Expenses section, and is starting specifically with the Category that has the highest amount of all the expense categories. It’s the Max value as defined in the spark lines column formula, but instead of filling the entire bar as the Income Max value category does, it’s only filling a fraction. Everything below it is then considerably off scale.

Update 2: The issue is that after Row 100, E through J are not merged horizontally as they are for the preceding rows. If you select all of the rows that are showing incorrect scale and choose “Merge Horizontally”, the problem is fixed.

2 Likes

Thanks for these updates. It sounds like you were able to work out a fix.

If you do run into any more weirdness with that template I’d recommend reaching out to our support team via the chat window in the lower right corner of the Console at https://my.tillerhq.com/

I am using the Savings Budget and associated Savings & Debt to track my budget.

One of the recommendations (“Debts and Loan Tracking”) is to name both the Debt inflow and outflow using the same category, to ensure that it is appropriately tracked in both the sheets. In my case it means that my mortgage inflow (i.e. into my Mortgage account) and my mortgage outflow (i.e. from my Checking out) have the exact same category. This is how the Savings Budget is intended to work.

However, this introduces a problem in the “Spending Trends” sheet. This sheet lists all the outflows for each category. Because my mortgage inflow and outflow cancel out, my mortgage “spend” for the year is $0. This impacts the overall cash flow accounting for this sheet.

Is there any solution to this?

I have the category name matching for the mortgage outflow, and the account name matching for the mortgage inflow. That seems to work for me. I use different categories for the inflow and outflow (for my own personal method of understanding these things, I process the outflow as an expense [i.e., for housing] and the inflow as a transfer [i.e., reducing the loan balance]).

Good to know. The Spending Trends sheet installs with 100 rows out-of-the-box, and apparently adding new rows doesn’t inherit merged cells formatting.

90+ categories/groups sounds pretty granular, so maybe it doesn’t occur often. I have roughly half that amount, just checking to see how close I am to reaching row 101 :slight_smile:

1 Like

I am getting a #NAME? error in all the formatted cells on this page. It looks like there’s an error in the hidden columns starting with AC3 and going all the way right. All those cells are throwing the same #NAME? error. I’m not sure what those formuals are supposed to be so I can’t troubleshoot the error. Has anyone else seen this, and if so, how did you fix it? TY!