Savings & Debt Sheet - Error Pulling over Transaction

I’m having a weird issue with the Savings & Debt tab not pulling over a transaction deducted from one of the categories.

In my Savings Budget, I have a vacation expense of $600 this month. I only had $500.89 in the fund so the balance is now -$99.11. But when I go into the Savings & Debt, it’s not picking up the $600 expense.

I’ve been digging around, and the odd thing is that if I duplicate the line item in Transactions, then the Savings & Debt does pick up on it and records it as -99.11 on the tab, but then my Savings Budget tab is now duplicated (because there are two identical transaction rows of $600), and thus it thinks I’ve spent $1200 and am -699.11 available.

I have deleted the Savings & Debt tab and have reinstalled, but same issue persists. It’s clearly this tab that is having the issue as Savings Budget is working correctly. I can’t for the life of me figure out what is going on – and it’s only that one transaction & category. Everything else is fine.

As a troubleshooting step I’d try changing some of the values for the transaction to see if it makes any difference on the Savings & Debt tab. I’d start with Category, then also try Date and Amount.

I’d think it was an account or category setup issue if not for the fact that creating a new transaction does work. Does it matter where you add the second/test transaction (i.e. bottom or top of the Transactions sheet)? Sometimes cell references can accidentally move off the initial rows in a data set (though reinstalling the solution would likely address this issue).

I noticed that the Savings Budget is a dependency for the Savings & Debt template. You might also consider restoring that sheet in case cell references were accidentally moved in that sheet (e.g. from manually inserting rows).

Thanks all.

I had played around with those last time to no avail. The one odd thing about this transaction is that it came out of my checking account (it was a check rather than a credit card transaction). I just did a tiller refresh, and I think it is working.

I’m wondering if maybe the $600 was pending? But I don’t think Tiller grabs pending transactions, and it still didn’t make sense why the Savings Goals tab was correct but the Savings & Debt wasn’t.

I’ll keep my eye on this, but for now it looks to be correct.

(Maybe it’s just a case of when you ask for help from the IT engineers, they come to your desk, and then the problem suddenly disappears! But my issue, I swear, lasted over 4 days, until yesterday. I wasn’t going crazy!)

I’ll consider this solved for now!

Thank you,
Doug

To me, it sounds like one of those range issues where a query is hitting A2:A and some rows are inserted in a way where the query remaps to A10:A… such that the first few rows are no longer included in the query. It’s possible that the new transactions pushed the missing transaction into the adjusted query range. I wonder what would happen if you dragged the missing transaction up to row 2 in your Transactions sheet.

Glad to hear it is working though.

Randy,
I think you have ID the problem correctly. My old vacation transaction is now row 44. So I did an experiment: the transaction that now lives in row 2 I changed from “Transfer” as a category to “Vacation” (this transfer was -$2,000) Savings Budget Tab recorded this a -$2k in Vacation, but the Savings & Debt tab didn’t change the Vacations line.

So is the script wrong in the Savings&Debt, not accounting for Row 2 from Transactions tab?

I don’t think it is a “script” issue. I think it is a formula issue in one of the templates. The most likely candidate is the Savings & Debt template and normally a restore operation would solve the issue. You said you tried that though? There is a small chance that the problem formula is in the Savings Budget template which the Savings & Debt template references.