TillerHQ Balances not feeding into Foundation Template Balances

Is there a reason why updated TillerHQ balances won’t feed through during a Fill data against the Foundation Template? I refreshed several accounts on TillerHQ this morning. On TillerHQ, I see updated balances (on my credit cards). But when I do a “Fill” within the Foundation Template, it says “No new data”. I’ve tried “Fill” several times and as of this afternoon, still the balances on TillerHQ have not fed through to the Google Sheets Tiller Foundation Template.

1 Like

I’ve been seeing something similar. I’ve been experimenting with Ultimate Envelopes (and liking it very much, btw) but for the last 2-3 days several of my balances have not been updated. On the Tiller HQ dashboard, the balances ARE correct, but not on the spreadsheet.

Below is a screenshot of a column on one of the UE worksheets showing when the account balances were last updated. What strikes me as odd is one account does seem to be updating (and, until this morning, the one directly below it—last one on the list—was also updating. But this morning, it reverted back to its balance 3 days ago). It’s a savings account at a credit union.

Of the ones not updating in the upper section, 4 are credit cards and one is a checking account. The checking account is at the same credit union as the savings account that is updating (the account in red can be ignored—it’s a manual credit card I added, so I’m not concerned with that one, as I haven’t done anything with it since playing around with adding a manual account).

Ultimate Envelopes works in conjunction with the Foundations Template but is a separate workbook, so I was curious if others using the Foundations Template were seeing something similar.

I’ve been trying to figure out if I inadvertently did something on my end to cause this or if there was a problem with the balances feeding through that was happening somewhere else. So far, no clue…

My two Credit Cards updated again last evening. So the connection is there. It seems to me as though “Balance History” is only updated when there are transactions to post or once a day if there were no transactions. I have a dialogue going with Tiller Support and will see what they come back with.

The two Credit Card accounts are interesting. Around 7pm they post new transactions, but the balance on the account is not adjusted until the next morning. This is what leads me to my theory. When there were transactions to post at 7pm, the balance at the time was still stale, even on TillerHQ. In the morning when I “Refresh” accounts on TillerHQ, TillerHQ registers the updated balance, but there are no new transactions to post for the account…and the balances don’t feed through to the Template. At least that is what I’m observing.

I was actually wondering if that might be the case, too, but 2 of my credit cards and the checking account have all had transactions in the last 3 days, that have shown up in the Transactions sheet, but the balances still aren’t updating.

Curious to hear what you find out from Support.

Check your balance history sheet. It is probably hidden. Check and see if you have current dates in it.

1 Like

Yeah, been checking that. But, no, the balances are not updated there.

In contrast, my Balance History sheet DOES have current dates, and the balances there for each account are correct. They’re just not making it over to the Envelopes sheet (I know we’re talking about a different template here, but the situation sounds similar).

Here’s dates and times from the last several updates

I think I may have found the issue with my UE template @richl and @n2linux. I took another look at the Balance History sheet and somehow a filter had been applied to the “Account” column. The accounts that were not updating had been hidden. When I turned their visibility back on the Balances on the Envelopes page updated.

I’m sure it’s something I did, at some point, but I sure don’t remember ever adding a filter to that page. But, I’m assuming I did and just forgot. Rich, thanks for helping to troubleshoot.

Glad you figured things out on your end. Sadly, no filter blocking my Balance History. Hopefully Support will get back to me soon and comment on the process that feeds balances in TillerHQ to the Template during Fill function and what criteria may be affecting things in my case.

Ah, bummer. I was hoping maybe that’s what was going on with yours, too. Hopefully it gets sorted out soon.

I have seen issues in the past where I will get two balance updates in one day and the balances sheet is looking at the earlier one cs the most recent one. I can’t tell if that’s the case for you. To fix this I delete the earlier balance

1 Like

I was looking at TillerHQ Help. It says “The Balance and Transaction data are not connected and pull in separate from each other.” So there goes part of my original theory. It also says “Tiller may refresh your loan, mortgages, and insurance accounts (and other low frequency accounts) less frequently.” It’s saying “refresh” and not “fill”, but I wonder if Tiller only fills some balance data, like credit cards, roughly once a day. Support should be getting back to me this week and I’ll post an update when they do.

I have never seen it only grab balances if there were transactions and vice versa. It always does both.

@n2linux I picked up your support conversation to try and figure out what’s going on here.

There were some changes made a couple months ago where folks were seeing newer balances in the Console (since those appear there now) but not in their sheets. Usually this was due to there being no new transactions available to fill. However, it seems like there is still some odd behavior here.

1 Like

This happens to me now ever since they updated to the new way they load fidelity accounts for example. It pulls in transactions but not an updated balance. The next day it updates. It seems to happen if it pulls data before the data is fully ready to pull - so when I run it manually I get the new transactions that posted since like 4 hrs ago or whatever but the balance doesn’t update til the next day.

I just encountered similar issues between last week and today. My balance updated closing last week as if the transactions had been downloaded. Yesterday, transactions didn’t update, and balance stayed the same as last Friday. This morning I received a duplicate balance transaction, and the bank transactions didn’t transfer. This afternoon, I refreshed again, and the bank transactions downloaded. Haven’t seen this before but I also have not checked my Tiller balance after my updates. Will be interesting to see if there is a pattern.

I heard back from support, and the issue is being cued up to the product team to look into. The interim solution in my case is to just refresh the Tiller Console once a day in the morning, when both transactions and the correct balances are available (for my credit cards).

I believe this is the new expected behavior with Fidelity investment accounts. We can only grab a balance once per day and will be the 8AM balance until the next day. I don’t know if this applies to checking/savings accounts.

Hi @david I’d recommend adding a feature request for this :slight_smile:

https://community.tillerhq.com/c/feature-requests/15

I tried to create a new topic under Feature Request, but it did not work. I saved my draft. Need an instruction on how to create a topic and save it.