Transactions in Chronological Order

The Transactions sheet in the Foundation Template defaults to reverse chronological order. Loading all new transactions up top. All good. That said, I chose to sort it in chronological order.

Why? B/c I have Zapier set up to add a new row in a different sheet every time a new row is created in the Transactions sheet.

My problem: Zapier only registers new rows at the bottom of the sheet, and the zap breaks when the sheet is resorted. And when I manually update my sheet from within the Tiller Money Feeds Add-on, it automatically resorts the sheet to reverse chronological and new transactions are added up top. So it’s a dual problem: resorting + new rows in the wrong place.

How can I disable this quirk?

Any help would be appreciated.

Hi @jack,
I don’t think the auto sorting by reverse chronological order can be disabled.

But, you could create a new sheet that automatically sorts transactions in chronological order and have Zapier run off of that sheet.

In a new sheet, enter this in A1:
=QUERY(Transactions!A:Z,"SELECT * ORDER BY B")

This assumes Column Z is your last column and your Date Column is B.
Adjust Z and B in the formula to match your transactions column letters.

The new sheet will auto sort your Transactions in chronological order.

Let us know if that works for you.

Jon

@jack we just released this feature to help with this!

I love it. Thank you!