US Bank -- Bank Feed Not Updating

Bank feeds (specifically on my US Bank account) have not worked this past week. I’ve tried about once per day – most every time they have timed out. However within the last 2 days I’m getting an “error message”. Any other US Bank customers out there having issues?

1 Like

I should also mention, the only troubleshooting I have done outside of hitting the “refresh” button is hitting the “connection” button when logged into my main Tiller account (not inside the spreadsheet via the extension panel). I re-entered my log in credentials but that didn’t work. Hesitant to unlink my account as I have yet to do that with any of my accounts in the last ~14 months of using Tiller

I’ve had the same issue for over a week now. U.S. Bank is listed as an outage on the Tiller Institution Outages report which you can access here:

[Tiller Institution Outages] (Institution Alerts - Google Sheets)

The report is comprised of updates that Tiller gets from Yodlee - the data aggregator they use. Click the link in the upper right-hand corner of the listing for more information on how to read it.

My experience has been that whenever the problem lasts for more than a few days it is because U.S. Bank has made a change to the download process on their end.


Super helpful, thanks @fehegner. Will keep an eye on this list over the next week or so

I would venture that this is on the US Bank side. We’ve been having issues with mobile deposits for a few weeks now. Wife went by the branch and they said that they either changed providers or something and were having a lot of issues right now.

I just got a pop-up when I logged on to my USBank account saying they are working on the backend over the next several months to speed up online access. Fingers crossed that our connection starts working before “months”!

No kidding. Going on 14 days here which is long enough. Might have to look into manually bringing them in for the time being

Having the same issues over here, super frustrating as it’s end of month and I have the majority of my main accounts through USB. Seems like there are always issues between Tiller & USB. Can’t wait for the day USB allows open banking!

Hi All,
I just finished a call with USBank technical support. I told them several of us that use Tiller have been unable to download our USBank transactions via Yodlee for over two weeks. They said that they have not had any problems with any of their data aggregators and that they do not support, or trouble shoot with Yodlee directly, so our only recourse is direct contact with Yodlee. I don’t know of any way for us individually to contact Yodlee so will follow up with Tiller folks directly to see if there are any other updates besides what’s on the Outage Report.


Update to my last post: Since USBank is on the Outage Report it means Yodlee is aware of and working on the outage so our best bet for now, if the issue isn’t resolved by the current projected 3/4 date, will be to manually import if you don’t want to wait any longer.

The Outage Report date was just updated to 3/14 now. Ugh. Has anyone sent a note to Tiller Tech Support?

So two weeks and the date has changed to next week. Since this is the only bank account I have it has rendered Tiller pretty much useless unless I want to go back to manually entering everything. “Site is down…” really doesn’t strike me with confidence that this is getting fixed soon. I have only been using Tiller since Mvelopes closed down at the end of the year, I would really hate to have to move to yet another tool.

@ryanstraits I tried but it won’t let me past all the automated responses.

The irony…Makes me wonder if this is a Tiller side issue…

Hmm, interesting. I don’t know but I am noticing a lot more of my feeds having issues lately. Even Chase today won’t update which they use open banking. US Bank being down has nearly broken my use of Tiller. Very frustrating. If no one else has submitted a ticket with Tiller CS, I will go ahead and do that just to make sure they’re watching it as well.

“Tentative ETA” has once again moved, now 3/20. I have tried to reach out to Tiller tech support via their chat bot, but it won’t let you past the bot to a person given the responses to the bot questions I have tried. like @fehegner I also reached out to US Bank and they said they are aware of no issues with their data aggregators and have not been notified by any third-party services of connection issues.

This would lead me to believe this issue rests with Tiller not the bank or Yodlee.

All other feeds Chase, First Bank, Citi, all seem to be working fine.

Ok yeah they’ve changed the auto responses on their CS feed, I’ll try a different route. Annoying that the date pushed out again.

We’ve talked directly with our technical account manager at Yodlee about the U.S. Bank issue and why it’s been ongoing (for really over two years now, it’s been on and off the outage/site alerts dashboard). He indicates that U.S. Bank keeps making changes to their website. Sometimes these are changes to the UI/site design, other times they’re changes to the back end technology and are not obvious to users.

He mentioned that they do not have a close relationship with U.S. Bank the way they do with some other institutions and so the changes are not proactively communicated to Yodlee and thus they are left to react and try to fix the changes after they’re made.

He did also indicate the U.S. Bank is tentatively scheduled for open banking enablement in Q2 of this year. We do not have an official date at this time.

I’m sorry that we don’t have a better outcome here, but the best case scenario is that open banking will address this ongoing issue.

There is about a 23% success rate for refreshes for U.S. Bank for our customers right now.

Thanks for your patience.


Thanks for the update, Heather! I agree that USB has had the most consistent outages of all the accounts I pull in through Tiller. It’s strange that they wouldn’t work closely with Yodlee when (as noted above) that is the service they use to pull in 3rd party data. At any rate, it’s helpful to have this background info.

Crossing my fingers that open banking gets implemented with USB soon!

Thanks, @heather !

One question for you as I pulled in a chunk of transactions manually the other day. If I do see success in a refresh, will the Yodlee feed only bring in “new” transactions that aren’t already in my transactions list? Worried about trying and bringing in duplicates…