US Bank -- Bank Feed Not Updating

@heather Thank you for the update, this is incredibly helpful to my understanding of what the situation is. I will keep trying to refresh to see if I get lucky to be part of the 23%. In the mean time I guess I echo the question from @dburke03 if I do a manual import of transactions to I have to be worried about transaction duplication? I mean this is a possible workaround until USB get’s their act together as long as it doesn’t cause a larger mess in the long run.

@andy @dburke03 In my experience there will be duplicates, but Tiller may have improved their workflow and I’m not aware of it. The tool that I have used in the past (including just recently so I could close out my February budget) was the Tiller Community manual CSV bulk upload tool. When I’ve used this and the automatic feeds came back online there would be a lot of duplicates, however, since I don’t use AutoCat they were fairly easy to spot and weed out. It’s a pain, but not horrible. As Heather mentioned, until USB joins the Open Banking game, we are likely to keep fighting these types of issues. Things like this definitely make me appreciative of when all my feeds are updating automatically!

@ryanstraits thanks for that insight. I can live with that, with the hope of a better solution maybe on the horizon. Probably better to just do the manual import than to play roulette with trying to get the account to refresh…

Unfortunately looks like the bulk import is only for Excel, and I am using Google Sheets… Will have to figure out another way.

I use it with Google Sheets.


I just found that in my searching… LOL! Thanks for the info.

1 Like

I appreciate that this issue is being worked on. I was really hoping to avoid manually importing everything. This outage has been ongoing for over a month now and has rendered Tiller completely useless for me. Frustrating that I paid for a service with such great reviews and it has only worked for about a week of my subscription. Might be going back to Mint so I can track my daily transactions without manually importing all my data.

Hang in there, i feel your pain over manual imports as I’m heavily a USAA user, and havent had imports in over 5 months. Theyll get it figured out.

1 Like

Hi @heather - have you received any additional information regarding the US Bank + Yodlee connection?

@dburke03 we have not received additional information about this connection other than an open banking connection is supposed to be live at some point this year.

If you’re going to do a manual pull, you’ll need to do it permanently because the system puller won’t recognize those transactions and in that case you might as well take it off the list to update

@heather thank you for the update. Not great news, but it is what it is.

I’ve been using a separate file to download the transactions I need to upload, then creating enough open rows in my transactions list to paste the new line items. So far it’s working fine… but annoying to do for ~5 accounts.

@dburke03 I have been using the csv import that @ryanstraits recommended. It actually works really well and at least isn’t completely manual as it allows for bulk upload of transactions. I know it will require some manual clean up if the USB connection ever gets fixed, but luckily I have a limited number of transactions through those accounts. Still a pain, but it will work ubtil it is fixed.

1 Like

So my USB accounts started updating again yesterday. I got all my USB CC transactions loading automatically into my Transactions sheet, but not the transactions from my Checking account. It’s weird because all my USB balances are loading into my Balance sheet again. So still seems a little glitchy, but all-in-all I’m happy to at least be getting something coming in automatically again!

1 Like

I came here to comment the same thing, Ryan. USB CC now working great, but nothing from checking, which is sort of the point for me.


Interesting… I am not getting an error anymore, but unlike others nothing is updating. Balances still say last updated 50+ days ago and no transactions loaded (so that is the same as what others are seeing).

Yep same thing here. Although not all of my accounts’ balances are being updated. Looks like 2/5 are.

The sync appears to be working but no transactions come through… hopefully we’re getting closer on this and transactions will start to show.

Has anyone thought about copying/pasting all of the autocat rules into a separate spreadsheet then deleting the ones in the Tiller sheet so when the transactions do eventually pull through, they will be easier to find and remove? Was brainstorming ways around the autocat feature reconciling transactions before I’m able to identify / delete them manually

I’ve been building an app in Appsheet to run budgeting automation on top of the tiller spreadsheet and I’m loving it. It really breaks down the door for what’s possible. In then end, I’m paying Tiller to aggregate my transactions to a spreadsheet, which I think is worth it for $5 a month as long as it actually works. My plan was to filter by account and then run a duplicate analysis over description/date/amount and then delete by the newest added, since I’m adding additional data to the manual import transactions in app.

How’s it going with U.S. bank connections today? Are you seeing balances/transactions update as expected. We received word from our technical account manager things should be working as usual, so I want to validate that with you all. Thanks!