USAA transactions and balances not updating

I also use USAA and up until this point have had success with importing transactions until just a few days ago it seems like. It is currently about 3 days behind of transactions and 2 days of balance history. What I find odd is that my 2 credit cards which I haven’t used lately continue to get balances but the account numbers have went blank. It is also showing a blank spot on the account number on the Tiller dashboard where it usually says the xxxx1234 part.

Those that are swapping banks over this, is USAA doing any kind of closing out interview to find out why your moving business elsewhere?

Not sure if it’s just my lucky day or what. But, I’ve been trying to update my transactions from USAA for 100+ days and, out of the blue, today all mine updated perfectly.

It’ll ask for a security code now. But the first time it updated balances without downloading transactions, and now it times out…every time.

Just ran an update. I didn’t get a timeout—after inputting the security code, balances populated. I haven’t had any new transactions since Friday, so I can say for sure if transactions are pulling down or not.

I can get it to refresh if I click outside of the box when it connects - but it won’t bring down transactions. That, for me, is the most important part. I haven’t had USAA transactions since the beginning of October. This is really frustrating.

The workaround to click outside the window when it gets to the “gathering details” step does work for some people to get transactions and balances it seems like ONLY IF you’re not also prompted for some type of additional security code sent via text message. However, I don’t know if this is true 100% of the time.

I observed this on a call with a customer the other day (not related to USAA issue, related to some of the legacy migrations that are ongoing and she just happened to try refreshing USAA). She did not get prompted for any type of 2FA and I had her click outside the window when it got to “gathering details” and then she got some transactions/balances.

For those of you getting balances, I’d recommend double checking they are actually the current balance. Sometimes the system will seem like it’s pulling in a balance, but it’s a stale balance.

Once again, this issue is somewhat specific to the transactions because it’s a transactions page load issue

@TomWIN as far as CSVs go, you can export a CSV from USAA and then use the Basic Bank option in the Tiller Community Solutions add-on or my preferred option is Randy’s Simple CSV Importer - it’s a bit more manual effort to set it up, but I find it’s more customizable than the built in Basic Bank CSV option. Last, he also built a spreadsheet based CSV import helper tool.

Basic Bank CSV: Docs: Import CSV Line Items
Simple CSV Import (requires adding script manually using Script Editor): Simple CSV Import Workflow (for Unsupported Data Sources)
CSV Spreadsheet Importer Multi-tool: CSV Spreadsheet Importer Multitool for Google

I wanted to provide some information here given that I’m a long time USAA customer (16+ years) and have been experiencing these problems. I am new to Tiller and was hoping that switching financial tracking services would resolve my USAA sync issues on my former platform, and it didn’t. Seeing this, I became curious and tested multiple financial tracking/budget services that I won’t name here in case they are removed or it breaks some rule, and none sync with USAA. I am currently in chat with USAA right now and they’ve informed me that they moved to a new MX based platform and that appears to have caused the problems and told me to use their internal budget solution (which is garbage and doesn’t help with the external accounts). I told them that they would lose me and many others if they didn’t resolve this, because this is a very basic banking service that is expected and not providing that is a dealbreaker for most people. They said they would pass along the complaint but I’m not confident it will go anywhere. That said, if enough people reach them and can request that the feedback be passed on, there is power in volume of voices. Anyone who is willing to take the time to do this - ask for Website Customer Service.


Noted, @khawkov. Thanks for the info. I’ll definitely register the complaint. There’s no doubt their IT systems are hot garbage. I don’t use them as my primary bank for this and many other reasons. Unfortunately, for my insurance situation, they can’t be beat and having at least one bank account with them does net some savings on insurance. So, here I sit. :slight_smile:

I don’t blame you for not using them as the primary bank. If I wasn’t in the process of pulling together a new mortgage, I’d be moving right now. But I completely agree - their insurance rates are second to none for me.

Hi @khawkov thanks for sharing. When I called and spoke to web support they told me they didn’t have any information on data aggregation and it was dead end… it’s frustrating that their support team members all have different info.

I did get my first “successful” refresh today and brought in new balances since July, but still no transactions.

I’ve been with USAA since 1988 and am really disappointed here. I’m going to start migrating auto-pays and credit cards. Is there a link on the web site to complain, or you need to call? Thanks.

I tried to go through chat and they told me to call. From what I can gather, connections to USAA that use Plaid are working; connections that use Yodlee are not. Not sure if Tiller is interested at all in Plaid, but that could be a solution if USAA just flat out refuses to play ball.

1 Like

@khawkov thanks for these details. Unfortunately, just switching to Plaid would likely take us longer than it would for Yodlee to fix their integration with USAA. Switching data aggregators or enabling additional ones is a huge undertaking and not something we’re able to do at this time, but definitely on our radar for the future.

1 Like

My transactions have now stopped as well. It had been working fine until I was switched over to the new MX platform a couple of weeks ago. Looking through the USAA community you will see many threads on this issue with yodlee that are nearly two years old. I seriously doubt this will ever be addressed. There’s also a super long thread indicating that Quicken will be the only option. Time to move on.

1 Like

Just for kicks I logged into my old account, and updated USAA. It said “hang on while we fix your account…” and then “FIXED”. All transactions loaded fine.

I think you need to give Yodlee a swift kick in the pumpkins for everyone that has a USAA account.

We’ve been trying to give them that swift kick for a while. Doing no good.

If you do end up getting the data via Mint, you can easily export a CSV file and then use the Tiller Community Solutions add-on to import the data into your Tiller spreadsheet.

I called USAA Tech Support. She told me Tiller has been added to the “Unsupported List.” She drafted a note to the Dev Team asking them to remove Tiller from the Unsupported list.

Background: I logged into the Tiller Consol and refreshed my accounts while she watched on her end, authentication worked just fine, but no transactions pulled-in.


Any idea how many Tiller users have USAA accounts? I am trying some of my connections there & willing to eat up my 15 InMail credits on LinkedIn to try the right people

Thanks @heather FYI this might not mean anything, but I see the below in my browser console when trying to refresh. Kind of seems to suggest that Yodlee is rejecting the tiller authentication. I am still getting this new(ish) error too.

[Report Only] Refused to send form data to ‘’ because it violates the following Content Security Policy directive: “form-action”.

@CaptainDrew the report only csp header stuff is just that, report only so it’s not actually blocking anything, but I’ll pass to our engineering team anyway.

The issue with USAA is squarely in USAA’s boat. Once again, Yodlee needs USAA’s cooperation and they are not being cooperative or responsive at this point.

@kyle I can’t share specifics and folks at USAA will not really know who Tiller is but rather Yodlee, our data provider. USAA is a high volume site, meaning they are in the list of institutions that make up 95% of the refresh volume among all institutions across Yodlee’s entire network of more than 20K institutions.

@robdog151 this is surprising to me. Per my note above, I don’t really think USAA has any awareness of Tiller. The refresh is expected to succeed but no transactions will come through due to the page load issue.