USAA transactions and balances not updating

Been a USAA member for 50 years. Banking. Insurance. Wealth Management. Investment vehicles. I am slowing returning to basic insurance needs. I canceled my 3 USAA credit cards recently as USAA does not support the Open Banking Standard. Every other financial institution does (that I use). Except maybe my new Apple Savings account at 4.15% interest. Get with the program, USAA Federal Savings Bank.


USAA responds to feedback provided from their Facebook page if you’re willing to login to a Facebook account. That’s the easiest way I’ve found to reach them.


:wave: @EdDziuk, welcome!

Definitely feel free to reach out to them and urge them to fast track the open banking connection they’re working on with Yodlee!

Hi @heather - Any updates on the open banking connection with USAA?

Thanks for all your help,


I am wondering the same…


Hi @kyleleechicago - nothing we can share just yet, but real progress is actually being made!! Hopeful to share an update soon, just waiting on our Yodlee account rep to reply to my latest email so I can share an update.


Just fyi, I use another service that relies on Plaid, and it syncs with USAA. I am excited for your update like so many others (including Peter evidently).

1 Like

I’m done waiting for USAA to get their act together. If this isn’t solved in the next 30 days, I’m opening a new bank account with Schwab and moving everything over. Absolutely totally unacceptable. I’ve now lost data thanks to these fools.

1 Like

Good news, folks! USAA is back online with Tiller with an open banking connection!

We really appreciate your patience as we’ve worked closely with our data provider to resolve the connectivity issues with USAA. As you know, this has been a top priority for Tiller, and we’re thrilled that Yodlee has invited us to be part of their very first test of USAA’s open banking implementations.

Early testing access for USAA open banking is now live. To upgrade your connection and pull approximately ~90 worth of transaction data for your USAA accounts:

  1. Open your Tiller Console at
  2. Click “Connection > Edit credentials” next to USAA under the Connected Account Summary & follow the prompts to log in and connect

We’re giving the community here a first heads up and will also be sending emails in phases as we get feedback about how it’s going over the next couple days.

We’re already aware of some formatting/sizing issues in the open banking account selection screen where it’s not quite fitting into the size of the pop up window after logging in directly to USAA via that pop up. We’ve already let Yodlee know about this and we expect they’ll address it pretty quickly.

If you find other issues, please reply here and let me know!


Fantastic news. Working on my end so far.

I basically gave up on tracking my USAA accounts during this outage. Does anyone have a process for retroactively uploading data over 90 days old?


I was manually updating via export to CSV and uploading to Tiller. But now I’m expecting to have a lot of duplicates. If I figure it out I’ll post it here.

Hey @kyle glad it’s working! This is the best resource for manually importing data to fill in that gap. How to Manually Import Your Bank Data | Tiller Help Center

1 Like

Wow! Can’t believe it!!! Thank you!!

1 Like

This works and I am so very thankful for this.

Now my sidebar has the following and it makes me so happy.

For those who have been manually importing, something I thought to do prior to the fill from USAA was to filter out all USAA transactions and add a column that indicates that it was the manual transaction. Not sure if that will be helpful to any others but I intend to just go through and make sure all of my manual transactions matches before deleting any duplicates.

Thank you Tiller Team and Yodlee for this integration and getting this up and working.


Glad this is up and running - great news! When authorizing with USAA the prompt requests both banking account information and account owner information (name, email, phone, etc.) - is account owner information necessary to sync the banking data?

That’s a great question. I don’t think so but I don’t know 100% for sure. You could try unchecking it and see if everything goes as planned :slight_smile:

Heather, the new link to USAA worked like a charm, except it didn’t update my net worth sheet. I see the updated balance in the balances sheet, and see that it downloaded the last 90 days of transactions.
Any ideas why the net worth sheet won’t pull the new USAA balances in?

Update: Disregard, I waited a day and the new balances showed in the Net Worth sheet. I guess it pulled 1 Aug data, and the sheet was still only showing 31 Jul. Regardless, it seems to be working now.


I was able to initially connect and transactions from the last 90 days easily downloaded but now I am getting an error when trying to refresh and transactions are not downloading anymore. See error below. Is there a known error going on?

hi @jeff.kvalheim - we don’t have any known issues. However, I would recommend trying to let USAA refresh on its own vs trying to force a refresh. It should automatically refresh again in a day or so. If it doesn’t auto refresh and bring in your data in and you’re still getting this unexpected site error, please write to us via the chat tool in the lower right corner of the Tiller Console at

I think I figured out the issue and thought I would post here in case others have the same issue. If you log on to the website you have to select the log out button before closing out of the webpage. I usually just close out the webpage when I am done with my business on rather than selecting log out before closing out the webpage. I continued to get the error as shown above but once I logged into and selected the log out button and tried to refresh again it worked.