Venmo not connecting again

Is anyone else having issues with Venmo connections again? My account has once again started returning a connection error. This has happened before (as I see it had with many others), but was fixed and added a 2fa to the refresh. Now I don’t even get a prompt for the 2fa code, simply returns a connection error with a message stating no know fixes if ever can be stated.

Is there a fix in order or will Venmo have to be manually imported from here forward?

1 Like

I haven’t been able to get Venmo to work for several weeks. Sometimes I just get the connection error. Sometimes it “resets” (loses my password) and I login and it fails then. Every few weeks I get the 2fa, and once in 2 months it worked, otherwise the 2fa fails. Venmo used to work perfectly, and is important! I submitted a service request, and it was apparently forwarded to the connection vendor.

Also having issues - will sometimes get the 2FA prompt, but it never actually connects and downloads transactions. Haven’t been able to close September because I’m missing too many transactions.

Me too. I’m not a big Venmo user, so only ask for updates on console sporadically. Failed twice this morning after receiving/entering 2FA prompt.
Fails with “Technical Error”

I do get email from Venmo informing me that a “New Remembered Device” has been added.

Venmo is on our Outage list. Institution Outages - Google Sheets

The “action required” steps don’t seem to be helping folks so I think they have that description wrong and there is definitely some other technical issue.

I’ve been having the same problems as you on and off for about 2 months with no successful sync for the last 3 weeks but just wanted to share I finally got the 2FA to work this morning so hopefully that’s a sign that things are working again for others as well.

1 Like

I was able to get the 2FA to work here and there as well.
Heather did post that Venmo was on their outage list. Hoping to see the connection back to fluid soon. Otherwise, it will just have to be a weekly or monthly manual dump. Difficult considering I am using Venmo more and more lately to receive payments.

Seems there is another outage. I have had Stash connected since starting my Tiller connections, but today upon attempting a refresh I received an error notification that Stash does not allow outside sources to access the account. Does anyone have any insight as to what may be happening here?

hi @Chad_George - this thread is about Venmo. Were you having an issue with Venmo or is this about Stash?

Sorry for mixing this into the existing thread, I made the reply in haste as I was on my way out the door.
I am now having issues with Stash as well. Upon trying to refresh the account I now get a “Site is Blocked” error.

I’d recommend reaching out to our support team via the chat window in the lower right corner of the Console at

I’ve been having Venmo connection issues for weeks now too. The authentication is asking for both a credit card and expiration date to login, which doesn’t make sense. Has anyone found a work-around or are you manually entering transactions at this point?

Hi @emilya - we’re working closely with our data provider on this issue. We don’t believe that it should be prompting for full account number or card details so we do not recommend entering in that information to try and get it reconnected. They had a weeks long (or longer) outage and I guess are still getting things back in order. Thanks for your patience.

You can definitely manually track for the time being.

We found that when you log in directly to Venmo using an incognito session it will prompt for a second factor security code (2FA). The default delivery method is a code sent via text message to the phone number registered to the account. However, you can choose “confirm another way” and it does ask you to confirm you identity by entering either the full account number or card number that is the primary payment method for venmo.

We’re still working with our data provider to understand why they are skipping the default 2FA option and going straight to this alternate method. We understand our customers don’t want to enter these sensitive details in order to connect to venmo (it also may not actually work).

Thanks for your patience.

@emilya can you give this another try and see if it’s still asking for the card number and expiration or if it’s back to asking for a 2FA code sent via text? They said they pushed an update for this and I tested my own account, which was previously showing this odd behavior, but is now back to normal text 2FA.

It seems things were hit and miss there for bit and it does seem like there is some progress as now the issue is consistent. Upon refresh (Automated or Manual) the 2FA text is received, but the opportunity to authenticate with the code is never presented. The system goes straight to a notification stating there are issues authenticating credentials.

Current status with Venmo is that it will refresh successfully but it is not pulling transactions. We’re working with our data provider on this issue and we hope they will have it resolved soon.

If you use the CSV importer tool from Tiller Community Solutions there is a possibly a bug with the way the date timestamps are working. See advice here.

1 Like

Is the Venmo connection being worked on? I can get into Venmo just fine and I can get into Tiller. I can’t get Tiller to send a request a Venmo and Venmo to send a code, but then, when I put the code in, it says we’re having technical issues.

1 Like

Last update is 10 days ago from @heather (see above), @troraback.

My Venmo issue seems to have been fixed as of yesterday - a bunch of transactions from the past few months were downloaded. Of course, I had already added them manually so had to do some tedious clean up.