Weekly budget errors

I am having recurring errors with a weekly budget spreadsheet. I have gone through creating clean budget sheets 4 or 5 times, only for the error to either be there form the beginning, or, in the current case, to emerge after the sheet was working for 48 hours.

For whatever reason the rollover value is populating as N/A which is throwing the entire budget for a loop and cascading errors.

Hi @greg,

Sorry for the delayed reply here.

Have you tried restoring the dashboard? Add-ons > Tiller > Budget > Restore Dashboard?

That should correct errors here. Usually these appear when you’re directly editing the dashboard budget values. I’ve also seen weird errors appearing if any of the Amounts in the Amount column are not formatted properly as currency or have extra invalid characters (like a , instead of a .)

Finally, the template expects that you’re using U.S. date format month/day/year in the date column.

Let me know if none of that helps.


Hi Heather,
Unfortunately none of these tips resolved the problem. Do you have any other suggestions? This is really frustrating.


Hi @greg,

I noticed something strange in your budget dashboard image there, the text W01 is in the second column from the left for “Budget” where you have the VALUE! error.

To me that indicates something has gone wonky in your Budgets History sheet (the W01 code is used in one of the columns in that sheet to identify the budget).

Can you double check your Budgets History sheet and make sure that it looks and functions similar to the one in this video? The video also explains a little about what to edit/not edit in that sheet.


There were in fact errors in the Budget History sheet, and manually fixing them correct the errors. However, as soon as my next weekly budget period populated, the errors returned and I had to manually fix them again to remove the errors.


Can you let me know what the errors were on Budgets History?

We’ve seen this in the past and it’s almost always an issue with formatting in the amount column.


To clarify, these errors are appearing before I even tried to edit the budget history tab (or even knew it existed). The amount for each “Budget” since I created the spreadsheet is populating as W01 and Rollover as “n/a”. Rollover Mods are also populating as W01. If I manually replace each Rollover Mods as $0 and Rollover as $0 and manually enter each correct Budget line, the errors go away. But each week when the new Budget generates (this happens on Saturdays for me), the W01 and n/a fields snap back and the errors return.


I think @heather’s suggestion to restore the dashboard was a good one, but the problem sounds like it is upstream— in either Categories or Budgets History. There are three possibilities:

  • There is a bug in our rollover processing script
  • There is something amiss in your categories sheet that is confusing the rollover script
  • Your Budgets History sheet has become disorganized/corrupted in a way that the script cannot recovering from

The first case is possible, but we haven’t seen this behavior with too many users.
The second is also possible, but feels unlikely since that sheet isn’t complex.

Starting over with a clean Budgets History feels like the best bet. Are you open to creating a new spreadsheet? And running the Tiller/Budget/Start workflow on top of that?

You could even try our new migrator to pull across any categorization you’ve done. (Be sure to follow the steps and let us know how it goes.)

Good luck and let us know if you need further help.

I built a new weekly budget from scratch and no errors off the bat. I’ll report back once next week’s budget populates on Saturday if errors return.

And even before the new weekly budget populated, the errors returned overnight (during a time when I did not access the sheet). Since this is a branch new template, this would seem to point to bug in the sheet. One of my two income lines is populating as W01 for most values, which seems to be the primary issue. Unsure if the n/a’s are contributing as well. error

Thanks for the update @greg. I’m going to reach out to you via our other support channel and see if we can get this squared away :slight_smile:

Hi @greg,

Thanks for giving me the opportunity to explore this further with you. It looks like the Tiller Budget cannot handle a category called “Budget” I changed that in your test sheet to “Income Budget” and then re-ran Analyze Budgets History and that fixed it.

Let me know if you have further issues with it.

FYI @randy we should probably fix this at some point?


1 Like

Great catch, @heather. Thanks for your patience with this, @greg.

Are there any other category names that might trigger a cascade of #N/As, or anything else that can typically cause this problem? I am randomly having the same issue now with both my yearly budget and my monthly budget and I can’t figure out what I did. I do not have the Budget Add-on. Everything is showing up on the yearly and monthly budget as #N/A except for the Budget section, which shows $0.00.


@heather I started a new topic of this whole issue here. I was able to fix the #NA error (there still seems to be a glitch when adding Tags in Categories), but now I have a #VALUE! error.

Fixed it! (See new topic link above.)