Whack A Mole (1 Manual Acct with Red Caret Persists)

In my foundation template, I have 5 very simple manual accounts (a car, a house, a promissory note, and a nonfeed health savings account) with a very few transactions. Here they are:

My Account sheet persists in flagging ONE of these accounts with a red caret symbol (“Invalid Input must fall within specified range”). The dropdown list of accounts does NOT include that account - despite the Balance History sheet plainly containing its entry (entries). And of course that account then does not register in the Balances sheets or any reports. Presently, this is my car.

I am fairly certain this may reflect something the Tiller Money Labs Account Repair Balance History Tool created in some part of the template. Oddly, in using the Tiller Feeds Manual Accounts Tool, ALL 5 accounts are shown (but, again, in the Account sheet, the dropdown list does not, as this tool does, include the careted car account).

(One other possible issue is that I did not have a column called Month when the manual accounts were first entered; I added that because of your video on making a pivot table.)

I have tried to use that Tiller Feeds Manual Accounts tool to delete accounts and recreate them. When I do, I may restore the targeted account (yep, the red caret and invalid data error goes away), but ANOTHER one of the manual accounts gets the error and disappears from the Balances and reports. (For example, instead of the car account, the home account may get the caret, error and not appear on reports.) Its like a “Whack A Mole” issue! :grimacing:

Finally, if it helps, this is a list of the Tiller Money Labs Repair History Tool noting Account ID Mismatch(es):

There are so few manual entries, I would think there would be a way to fix pretty quickly by deleting and reentering or … But when I have tried in the past, the template becomes unstable and all accounts unlink.

Thank you for any help!

Hi @Larry,

It’s definitely the Account ID mismatches. Not surprising that the Labs add-on may have botched it (it’s an experimental tool … )

You can correct this by

  1. Saving a new manual balance entry for each manual account (even if the value is the same) using Tiller Money Feeds.
  2. Copy/paste the account ID from the new manual entry to all existing manual entries for each account by filtering the Balance History sheet on only those accounts entries one at a time.

That should reconcile any mismatches manually and then you may need to correct the validation error (red triangle) on the Accounts sheet one last time to ensure it’s using the newest Account ID assigned by Tiller Money Feeds.

If that doesn’t help you’ll probably want to restore the Accounts sheet (archive it as part of the process so you have a backup) using the Tiller Money Labs add-on > Manage Solutions > Accounts > Restore and then restore the Balances sheet using the same flow. Then re-configure the restored Accounts sheet.

Heather

Heather, thanks so much for trying to help me. I did the 2 step process and still no Subaru account to correct the validation error.

So, before I restore the Accounts sheet with the Resore tool, I am not sure what your directive to “archive the Accounts sheet” means. With right click, I have option to Copy To (and where – it won’t let me copy to the existing worksheet). or Duplicate?

(I have made a copy of the entire file on Google drive already, but want to this correctly.)

Thanks so much!

Hi @Larry the “archive” I was mentioning is built into the flow in Tiller Money Labs when you click “restore” it will prompt you to Archive or Overwrite.

Well the restore sheet tool did allow me to reconfigure and add ALL the manual accounts and allow for balance reporting, but then I notice that the Insights sheet does not have the graphing and all.

This Insights page now has no entries in Top 10 Acounts by Activity for any period; it has lost track of the Accounts Activity. Maybe that is inherent with adding the new Account sheet but disappointing it is broken.

Sheesh! Do I try to restore that sheet as well (haven’t checked if possible)? Have all the versions named and can go back but …

I restored this Insights sheet using the Labs restore tool and all is finally well. Thanks Heather and others!

Whew, for me lesson learned: very carefully back up archive | before when using the Labs tools. :grinning:They saved my bacon with these last efforts (restore sheets tools) but also messed things up for some very simple issues re my manual accounts (manual accounts entry tools).

1 Like