Missing some American Express Transactions in September

I have been missing a few transactions from mid-September for my Amex Platinum card. I tried doing a manual update but the transactions are still not showing. Has anyone else encountered this? Is there a manual transaction tool for excel if I need to enter these myself?

I have a regular AMEX and haven’t experience any issues. I don’t see a manual transaction tool yet for Excel, but you can still create a transaction manually by inserting a row into your Transaction sheet. I’d insert between rows 2 & 3 (avoid inserting at the very top as sometimes that does weird things to defined ranges). Manually fill in all the info, but leave the Transaction ID and Account ID blank. When you’re done, you can sort by date and all should be well. Keep in mind that at a later time the real transaction might download and you’ll have duplicates, so you’ll need to delete the one you manually entered.

Hi @buzzmaster1 We did have a service interruption on 9/1 and there are some steps in there to make sure everything got pulled, but if you received transactions around 9/1 and after already and are missing a few random ones from the middle of Sept for Amex I’d recommend checking out this guide if you haven’t already:

Sometimes a test sheet will have them and you can just copy/paste. Or you can manually add. Generally unless there is a consistent pattern with random gaps like that our data provider is not helpful in pulling them in.

I went through all the steps and there is no problem with my configuration and most Amex transactions are coming in. I created a new spreadsheet from scratch and linked only AMEX. All transactions downloaded. I was missing 5 in total. 2 on 9/14 and 3 on 9/28. Clearly, this is alarming as it is only by luck that I noticed there is a problem. I also noticed that the current order of columns in Tiller Foundation sheet is different than my original Tiller sheet. Why did Tiller decide to change the order? This complicates the process of copying and pasting in the transactions.

Hi @buzzmaster1

The fact that they showed up in the test sheet is interesting and I understand why you would feel it is alarming.

Before copying and pasting, I would make sure you have the filter completely turned off in your original sheet and then search for the Transaction ID (probably a hidden column) to be absolutely sure those transactions aren’t already in your spreadsheet. Sometimes filters or sorting can cause things to be out of order/not appear. The fact that they showed up in the test sheet means they should have made it into your original sheet.

The only reason I can think of that would have prevented them from making it into your original spreadsheet would be if the fill operation crashed at some point when you filled the sheet after those dates. Sometimes this can happen if you have a high volume of accounts (20+) and a lot of data in your spreadsheet or many dashboards. Usually this presents itself as the “fill” activity bar (the little animation that goes back and forth at the top of the add-on while you’re filling your sheet) getting stuck and never seeming to complete and not showing you the count of transactions and balances.

However, if that had happened, you’d likely end up with duplicates on a subsequent fill because the “watermark” didn’t get set that indicates where the fill last left off.

As for the column order, I don’t recall any changes recently that we made to the Google Sheets version, but we did re-arrange the Excel version of the Foundation Template’s columns to match the Google Sheets version.

I have not noticed the fill crashing but now I have concerns about what data I may be missing over the past few months. I am going to think about how to reconcile.

I am in excel. Changing the order of columns in the transaction sheet is absolutely ridiculous. You should have matched the order when you created the excel sheet in the first place. This change will now be a pain in my ass for perpetuity. I l tried to move the columns manually to match the order but encountered an error message. I would like a one-year free subscription.


Using the Account Reconciliation sheet is one way to tell if you’re missing transactions. It provides tools to help find missing transactions, and then you update it once a month when you get your statements, and it lets you know if your balances match those on the statement.

Thanks, how do I access this in excel?

Account Reconciliation - Excel - Microsoft Excel / Show & Tell - Tiller Community (tillerhq.com)

Thanks, I am setting it up now.

Hi @buzzmaster1 - sorry for the inconvenience of the column re-arrangement. A couple options are to re-arrange the columns in your sheet as you’ve already started to do or just start fresh in a new copy of the Foundation Template. I suspect you’ll get it worked out so that it’s not a pain forever :slight_smile:

Definitely an oversight on our part to not have them match initially.

I can’t offer you a one year free subscription at this time. :pray:

As I mentioned, I tried to rearrange them and encountered error messages. Starting fresh given the number of customized pivot tables and graphs is also not an attractive option. This is a significant error on the part of Tiller. I think a free year is very fair.

Hi @buzzmaster1 what type of error messages did you encounter when you tried to re-arrange them?

“A selection including cells both inside a table and below it cannot be copied and inserted into that table. Select cells outside the table and try inserting the data again” I have no idea what that means.

Try this:

  1. Click the header of the column you want to move (starting in row 1).
  2. Press ctrl+shift+arrow_down to select the entire column (assuming there are no blanks).
  3. Grab the selection with the four-arrow cursor and drag it where you want to position it.
  4. When you are between the two columns you want to place it you will see the green outline turn into a large “I” shape.
  5. You can release the selection now.

Based on your errors it seems like you are grabbing additional cells outside of your table range, so make sure you are only selecting your table range


enter image description here

So I tried this to no avail. For example, I highlighted the Check number column header and did ctrl+shift+arrowdown to select when I try to move the column, the error is: This won’t work because it would move cells in a table on your worksheet.

I think the problem is that most of the transaction sheet is a table

Now I noticed that a transaction for my Capital One CC is missing for 09/29. When I use a new template it loads. Not sure what to do now.

Regarding the missing transaction from Capital One, if it’s in a new sheet and you’re seeing it there, it could be in the other sheet, but out of order. Try sorting by Date in the Transactions sheet and/or try filling the original sheet using the Tiller Money Feeds add-in.

As for re-arranging the columns, the steps were specific to it being an Excel Table. I have no issue with the steps, but I think the key is not selecting rows below the table boundary and making sure you’re selecting all the cells in the table. You have to select just the cells that are actually in the table itself, but you have to be sure ALL the cells are selected in that column in the table boundary. If you use CTRL+SHIFT+ARROW_DOWN and there are blank cells it doesn’t automatically go all the way to the bottom of the table boundary so you have to keep tapping down arrow or just hold shift and manually click the last cell in the table boundary in that column. Some screenshots to demonstrate.

Thanks, Heather. I was able to arrange my columns to match the order in the current foundation sheet.

In terms of the missing transaction, no it is not pulling into my current sheet the same as the missing Amex transactions. As I mentioned in this thread as well as in my support request, I feel this is a Tiller issue since the data pulls fine from Yodlee in a fresh sheet. I would be happy to get on a call so that I can get more detail on how Tiller handles the FILL process and what might be involved in solving this issue as none of the suggestions thus far address the issue but instead are time-consuming work arounds that would have to be done periodically.