Random Missing Transactions

I have posted about missing transactions before but here is an update:

I am using the excel version. In the past, I have noticed missing transactions for various accounts. As far as I could tell, an account would stop updating for a few days and those missing transactions would never show up.

Today, I was updating my spreadsheet for 2023 and was reviewing 2022 activity. I was looking at my subscriptions category and noticed some payments were missing for 1 or 2 of the 12 months. Sure enough, I was missing a few credit card transactions from both Chase and Amex Credit cards. In the case of the Chase card, I use this particular card exactly once a month for this single payment only. The September 14th transaction wasn’t there. All other months and the autopay transactions were there. For Amex, there we some missing transactions for a couple of different cards on various dates.

Again as I mentioned in the past, Transaction Reliability should be the most important aspect of this product. I understand that Tiller is working with a third party. Nonetheless, it is in the interest of both Tiller and the 3rd party for this to solve these issues. Furthermore, my gut tells me that the issue is in the Tiller background that tracks which transactions have been added to the spreadsheet.

While Tiller works on this issue, a manual transaction tool should be added.

I am wondering if others have encountered this issue.

Happy New Year, Everyone

I can’t help with the reliability of Tiller, but my Account Reconciliation template could help point out missing transactions…

Thanks for your reply and sharing your sheet. I looked at it a few months ago but didn’t spend much time after an initial error. I am trying again now as it does not appear to be working. I selected an account from the drop down. Put 04/09/22 in column I and $1,664.56 in column J.
Then I put 05/10/2022 in column C and $1546.32 in column D. Tiller Ending Balance is blank with cell contents “=IFERROR(IF(” and column G is #VALUE. Not sure what I am messing up.


I just updated the shared template with some changes to the way I calculate columns E,F and G. Try updating, and if that doesn’t fix it, try leaving the padding zeros off the date, maybe it’s not smart enough to recognize them at dates (eg. 4/9/22 instead of 04/09/22). If that still doesn’t do it, and A5 is set to Enable, I’d probably have to look at your sheet to figure out where things are going wrong.

Thanks. I did pull in your sheet again and entered data with no padded zeros. Now colmuns e,f,g show #N/A

If you’re willing to share it with me (send a link via direct message) I’ll see what’s going wrong, otherwise I’m at a loss for where things could be breaking.

Hi @buzzmaster1 - we are hoping to have a manual transaction tool for Excel soon!

As for the sporadically missing transactions, I don’t think we can go back and grab the Sept 14th transaction now, but we did make a change around Dec 21 that we hope will address some of these small gaps that some folks experienced if our service encountered a small interruption.

Please let us know if you continue to find that you miss a random transaction going forward by writing directly to us via the chat tool on the Console at https://sheets.tillerhq.com/auth/login

Glad to hear that you are working on it and making changes. I sent a new chat and will be monitoring transactions closely to start the year. Happy new year.

1 Like

Hi Heather, I tried to start a chat but got a generic response from Morgan.

Morgan is doing a fantastic job :slight_smile: - she follows process to a T and without this additional context, she offers the correct response based on the context she has and I did not give her additional context on your case.

I replied via our official support channel. We’ll follow up here when we get to the bottom of this.

I responded to your new message and see that the conversation with Morgan has been deleted. I am not questioning Morgan’s ability/process however when I created the message, I didn’t write it up as an initial missing transaction message, I did include some context.