Problem with error: The data you entered violates the data validation rules set on this cell

Hey everyone,

I’ve been using Tiller since about October and loving it. I’m really just using it for basic expense/category tracking at the moment, but plant to start using the budgeting features in the future.

I recently purchased a car, and created a category “Car purchase” to track all of the expenses related to it. Everything was fine until just a few days ago, when I attempt to use that category, I get the attached error message (“The data you entered in cell D24 violates the data validation rules set on this cell”). I’ve previously used this category with no issue.

I also noticed that another category is causing the same error: “Auto maintenance”. It seems that all of my other categories are still working correctly (although I’ll admit I didn’t take the time to test every category). I’ve also previously used this category with no issue.

To my knowledge, I’ve made no changes to my sheet, just importing transactions and categorizing them appropriately.

Does anyone know what might be causing this error? I tried searching the community but couldn’t find any threads with the same problem.

Thanks!

:wave:, @eleazar123!

You can correct this by fixing the data validation rule on the Category column in the Transactions sheet using these steps as a guide:

Usually this happens because of the way rows are sorted or rearranged on the Categories sheet. Inserting or moving rows above or just below row 2 will break the validation.

Heather

Hi Heather,

Thank you for your quick response!

I followed the guide (see screenshot), but unfortunately I’m still encountering the error.

I made sure to select all the cells starting from D2 all the way to the end of my data. I also confirmed the column D is correct on the transactions sheet, and column A is correct on the categories sheet.

Can you double check that the categories are indeed on the Categories sheet and spelled correctly?

Yes, they are on the categories sheet, and spelled correctly. I haven’t modified these categories since I originally set them up (auto maint. i setup months ago, car purchase just a couple weeks ago).

I found another one that also doesn’t work: “Charity deductible”. This was also setup a couple months ago.

Anything else I can check that might help you troubleshoot?

@eleazar123,

I’ve just reached out via our support email system to help you with this issue.

Heather