Trouble with Pivot Table

Several months ago, I learned how to create a pivot table. This isn’t something I used all the time, so I deleted the one I created.

Now I’m trying to create another one, but when the Pivot Table Editor appears on the right of my screen, and I click Choose>/Add>Rows and try to choose category, category isn’t showing up at all.

I’m following the instructions on this page: Pivot table instructions

Am I missing a step? Have I screwed something up that can’t be fixed? Please help. Thanks!

When you select the data that you want to pivot. (Lets say the Transactions Sheet) be sure to secect the Column headings too along with the data. This is what Sheets uses to make the pivot selectors.

Then when you Go: Data - Pivot Table you can click on Row and see this data

image

OK, now I’m getting this (see screenshot):

I clicked the box in upper left hand corner that allows me to select everything, including the column headings.

Still need help here @sandral18706? When you get to the point of where you were in the screenshot you just click “create.”

But it sounds like you already created one?

heather, No, this is still isn’t working.

I clicked create, and went to Row-Add, and here’s a screenshot of what I see:

There is no Category there.

On your transaction sheet, make sure that Column D is labeled Category. It looks like you may have removed the column label as it is listed as “Column D” in your list. To do that just double click the column header and type in Category

Thank you–turns out that was the problem.

One more question: Now that I’ve created this will it update itself every month? Or do I have to create a new one next month?

1 Like

@sandral18706, it should update every month as long as you don’t have any filters set up (in the pivot table itself) to filter on certain months or categories. If you have any filters turned on in the pivot table’s settings you’d want to update the filters each month, but you shouldn’t need to re-create the pivot table.

Heather