Amazon Order History Reports Never Generate

yeah well looks like i spoke too soon. i can’t even squeeze out a week’s worth now.

1 Like

Thanks, @susandennis. I broke my report down into a few shorter time periods. Hopefully, they will run successfully, but I haven’t seen anything in the usual turnaround time yet.

Oh man. What a drag. I wonder if they changed some internal data schema and the report-generating code is struggling with the new format or if it is some EOY crunch by users trying to reconcile their 2021’s or holiday seasons… :man_shrugging:

1 Like

Considering all of the outages aws has had over the last few weeks and whatever hell they may be undergoing over the log4j security issue, this is probably a very low priority for them right now

As an update, the report I started on 12/26 failed sometime in the past day. None of the other smaller reports have finished or failed as of yet.

I had same issue of reports taking for ever and after 3 days of waiting - I finally got the CSV, only to realize the seem to have “Item Subtotal Tax” messed up (@randy - bringing this to your attention).

See Amazon “Import CSV Line Items” extension isn’t adding any tax at all for any of items for Dec 2021 - Get Help / Ask Anything - Tiller Community (

UPDATE: It looks like some issue on Amazon side - I tried downloading the report a second time and the issue remained and then retried again a few days later and the 3rd time was the charm and this time it got fixed.

All of my generated reports after the previously mentioned failed report have run successfully as of 1/1/2022. I have another report generated for 1/1/2022 - 1/3/2022 to see if the processing time has improved. It still hasn’t completed processing in the typical timeframe, but I will report back once it completes.

I seem to be facing that today…

Could there be an issue with csv uploads in general? I’ve uploaded trans for a couple years for Apple Card and Amazon but it’s not recognizing my csv doc (it IS csv) as a csv doc…

Hi @bpenrod33,

To be clear, the issue we’ve been discussing here is with Amazon generating the CSV reports for download, not importing them into our Tiller sheets. They have been taking substantially longer to generate than in the past. Once the files are downloaded, I am not aware of any issues importing Amazon Items and Amazon Refunds reports.

I can’t speak to the Apple Card CSV import, but it is possible that the structure of the CSV export has changed. If you can provide an example file, or at least the CSV headers, @randy or another Tiller representative may be able to see if there is anything that has changed compared to the format that the import script expects.

Following up on the report I started yesterday, it finished at 1:21 AM PST. I was able to run another report in under 5 minutes this morning. My guess is that the Amazon download order report service was overwhelmed with people running end-of-year reports, especially if many were running reports for the entire year.

Understood on the first point. As I said, I had the same issue. My Amazon report request says processing and then the downloaded copy never comes.

In top of that, I’m having an issue with the Apple Card transactions csv not being recognized as a csv doc.

As @cculber2 suggested, @bpenrod33, please send me a header and the first data row of your Apple Card CSV and I can see if the importer is setup properly for the current format. If you want to change account numbers or whatnot in a text editor that is fine… but be careful about deleting commas or modifying the data-structure integrity.

1 Like

Gotcha, thanks for clarifying. I incorrectly assumed you were having upload trouble for both sources. :sweat_smile:

@bpenrod33 i was able to upload my Apple Card CSV without issues.

To update the Amazon downloads, mine finally came thru yesterday including one for 2 months of items for my wife’s account.

Thanks Randy!

Transaction Date Clearing Date Description Merchant Category Type Amount (USD)
12/31/21 12/31/21 DAILY CASH ADJUSTMENT Daily Cash Adjustment Debit Debit 0.32
![image 690x15](upload://7AIwUV56wppQ80jMTNfcPOjQdE7.png)

Those columns match up with the importer’s expected columns for Apple Card— so I expect the workflow would recognize the file.

Would you be willing to share the file with me via DM? Possibly delete down to just a row or two (but make sure it fails on your end still after the edits)?


Update from a little earlier. I downloaded the statements again and instead of combining them into a larger file (the original was 5 months), I left them as individual files and uploaded them one at a time. That worked (but I definitely did 6 months for Jan-June 2021).

I did the same for Amazon trans (downloaded smaller files instead of several months) and they also uploaded without issues.

I ALSO rebooted both WiFi and my MacBook Pro, deleted cache/cookies/history, etc - so who knows what really happened/fixed the issue!

I’m going to stick to monthly downloads in 2022 for a couple reasons. I’ll advise if it goes astray for any reason!


Can you clarify… were you manually joining multiple CSVs into one larger file? Or were you just downloading larger data sets and importing directly?

In Amazon, I originally tried to download larger sets and upload them. When that failed I downloaded one month at a time and uploaded them without issues.

For Apple Card, I exported each individually and then copied/pasted into one csv file to upload (same as I had done for trans in the first half of the year). When that failed (kept saying “not a recognized format”) I exported them all again and uploaded to Tiller one month at a time (separate csv files).

After weeks of issues, my Amazon exports are working again today, just downloaded the 30 day report very quickly.

1 Like