Autocat Min and Max not working as expected

I think I may have found a bug with the new Excel Autocat. I am new to Tiller altogether, so I may be doing something wrong.

In my Autocat rule below I input a Max amount of 0, because I only want it to categorize Charges and never credits/returns to my credit card.

However, with a Max of 0, it doesn’t categorize anything. If I remove the Amount Max, then it will capture and categorize transactions correctly.

The Min and Max filters work on absolute values, @jesse.

Probably the best way to accomplish what you want is the Polarity filter. Just add an Autocat column called “Amount Polarity” and put the word “negative” in the appropriate cell.

Hi @randy thanks for the suggestion but that doesn’t seem to work. Is polarity available in Excel?
I added a column called “Amount Polarity” and input “positive” as the value to test it, and it incorrectly categorized my negative amounts. I renamed the column to just “Polarity” and tried again - same result. It doesn’t seem to respect the polarity of the amount.

The above rule categorized this below transaction:

OK I think I have it figured out.

I was not waiting long enough after changing autocat rules before clicking “Run Autocat.” I had to wait for the Workbook to finish saving before running Autocat for the rules to work correctly.

Also, the column must be title exactly “Amount Polarity” - simply naming the header “Polarity” broke the Autocat.

It works now. Thanks for the help.

Glad you got it working.

AutoCat rules are composed of “overrides” and “filters”.

Overrides are simply column names from the Transactions sheet and they identify what is written to a matching column when ALL filters are true.

Filters are in the format of [column name] + [filter criteria]. The column name identifies the column to apply the filter to and the criteria identifies the type of filter to run.

So, “Polarity” (a filter criteria) is meaningless without a column name to run that filter on.

TLDR; Column must be named Amount Polarity.


Autocat has stopped recognizing the minimum max amount column. I have been using is successfully for a month or so. I have somehow corrupted the Autocat sheet. I have tried to copy my inputs to a new sheet, but still no luck in seeing min/max values. Any suggestions?


@kra808 please out to our support team via the chat window in the lower right corner of the Console at and our team can help with this issue.