Autocat Working for Some Transactions But Not Others

After categorizing transactions, new imports are not categorizing repeating transactions. For instance, Trader Joe’s transactions do not categorize as groceries. This is true for other grocery stores I have categorized.

Also, some recurring income sources. I receive regular checks from some clients that are not automatically categorized although my Social Security auto deposit shows up correctly. The checks are deposited with a note of who they are from which shows up in the spreadsheet import but without a category. Am I expecting to much of Autocat?

@phooph, Do you have the Auto Run on Update setting toggled on under Tiller Money Feeds > AutoCat > AutoCat Run Settings?

Yes, the Auto. Run on Update is on.

I refreshed my sheet and redid auto cat rules, but when I run Autocat it is still is not working for most transactions.

I am having a similar issue as well. I’m trying to rename confusing/overly-long descriptions with Autocat, but most of the time Autocat doesn’t work. Sometimes it will sporadically work, but rarely. Did you find a solution to your problem?

And now it’s not working on categories either …

I saw someone else had posted on this issue in the past and got no answer. I suspect this is a challenging function. No word on if it is being worked on.

A couple things to keep an eye on, @caryupnorth & @phooph

  • Keep in mind that Autocat rules are processed top to bottom until a match is found, so a match found higher up could preempt a match further down.
  • Autocat can be configured to “Run AutoCat Rules On” on “Only Uncategorized Transactions” or “All Transactions”. Be sure to modify this setting or delete existing categories if you want Autocat to recategorize something.
  • Special characters— e.g. “smart” versus "dumb" quotes and extra whitespace characters— can be a real sticking point in matches. You mentioned a Trader Joe’s charge and the apostrophe immediately set off alarm bells in my head.

I just checked the crash logs and there don’t seem to be many issues with Autocat right now. My guess is that the problem is with your rules. If you aren’t able to resolve it quickly, I recommend opening a case with the Customer Success team. They do great work.

1 Like

Thank you for the very thorough reply, Randy. You were exactly right about two of my problems: the smart vs dumb quotes, and the Autocat moving from top to bottom. I went through my Autocat and found some accidental duplicates that were no doubt creating problems.

For future reference, which does Autocat want: smart or dumb quotes?

Also, should I avoid apostrophes altogether, or is there also a way to use them that won’t trigger an issue?

Thanks for your help!

Glad to hear those ideas helped.

Autocat doesn’t want either smart or dumb quotes. You, as the user, want whichever matches the text from your data provider.

There are probably ways to create an overcomplicated Regex Autocat rule which will accept either, but the easiest solution is just to match the data coming in from your feeds (it probably won’t change).

Oh okay. So for that, I should just copy the description directly and paste it with values only into my Autocat, correct? Also, I saw a Tiller YouTube video that said you could use quotes to add multiple descriptions into one Autocat rule (for example, rename description of “kohls”,“Kohl’s xxx089” to just “Kohl’s.” But whenever I try to do multiple renames using quotes with a comma between them and no space, Autocat doesn’t like it.

Have you tried selecting a transaction and having Autocat create the rule for you? There’s an option to create a Rule from Selection so I usually start with that and adjust to fit my recurring expenses.

I saw those settings. It did not seem to matter. It seems to work ok on subscriptions and my social security deposits and finally started working on PayPal which I categorized as Misc because I will have to hand sort those anyway.

Is autocat really disabled by an apostrophe? That seems unfortunate. Besides Trader Joe’s, I also shop at Oliver’s and Friedman’s. It also does not categorize CVS, Costco or Target. I don’t see any extra white spaces or quotes.

Also, I found others with similar complaints. Did not see any answers.

Thanks for your response. I will see what the Customer Success team can do.


Where does one find the Customer Success team? I see it nowhere and it does not show up in a search.

I wouldn’t say that “autocat really disabled by an apostrophe”, @phooph. It simply won’t match on a smart apostrophe if the value in your feeds is a dumb apostrophe— because, to a computer, they are two different characters. Autocat works fine with apostrophes, you just need to build your match criteria around the type of apostrophe you are matching to. Make sense?

The easiest way to get in touch with the Customer Success team is to click the circular Intercom icon in the bottom right of the main Tiller Money Feeds sidebar. They should be able to get things straightened out. Good luck.

Copying and pasting exact text may be the best approach… or you can use the Rules Builder as @RachelB suggest.

As for multi-match… maybe you are using smart quotes in the multi-match criteria, @caryupnorth? I use this in my personal Autocat rules sheet in the Description Contains column and it works fine:


1 Like

When I make a rule I select the cell with the transaction name and choose Make rule from selection. Is there something else I should do?

The quotes are working in Autocat now – I went through and checked that they’re all dumb quotes. I also now copy and paste when working with apostrophes in Autocat. Everything is up and running smoothly. Thanks!

1 Like

That’s great news, @caryupnorth.

If it is any help, I added a new topic about why & how smart quotes can be problematic.

1 Like

Yes, @phooph, clicking “Rule from Selection” will only recommend the rule. To actually create the rule, you need to subsequently click either “Create Rule” or “Create & Run”. I recommend reviewing and possibly editing the rule beforehand too. Good luck.