Balance History sheet does not sort itself

Greetings! I searched for my specific problem but nobody else reported it, so I’m sure it’s something I did.

My Balance History Sheet records all new balances at the bottom, so new balances are not seen by other sheets. If I sort it manually then everything works, but it does not appear to sort itself. Anyway to fix this?


If you have a data filter turned on, try selecting the entire sheet and turning it off after you have it sorted properly with newest dates at the top. Then check how it looks after the next fill.

It appears that I have no data filters turned on…

Have you seen this, @heather? Is it possible the fill operation is crashing after inserting the rows?

Welcome, @busflier :wave:

Can you double check whether the Auto Sort Override is enabled in the Settings section of the Tiller Money Feeds add-on in Google Sheets?

That would put all your balances at the bottom of the Balance History sheet and not sort them to the top.

The crash Randy mentioned would also cause that but it’s unlikely unless you have several years of data for >15 accounts and a lot of complex dashboards. You’d also likely see an error in the sidebar within a few moments of clicking the Fill button or the fill would never seem to complete (e.g. would not show you the count of transactions / balances added)

Hi Heather thanks for the reply.

The override is Off…and I did toggle it a couple of times to see if it would fix the problem.

I only have a little over one year of data and everything seems to be working fine. Just the Balance history glitch.



@busflier if you’re still having an issue here I’d recommend reaching out to our support team via the chat window in the lower right corner of the Console at