Money Feeds Does Not Update Transaction

Since the update to Tiller Money Feeds, my transactions are not being updated even though the accounts have just been refreshed. The account balances are updated but Money Feeds reports no new transactions. If I wait for 15-20 minutes and then refresh again, the transactions get updated.

I did not have this problem with the old Tiller Money Feeds extension. Is there a problem with the new Money Feeds or is there a setting that I need to change.?

1 Like

I’m having this same issue. My first cup of coffee morning routine has been to refresh my accounts and fill my sheets. Since the update, I refresh my accounts, but the fill doesn’t fill in my transactions immediately. I’ll check an hour later and the transactions are there. Not the hugest deal in the world, but it’s messing with my morning flow.

1 Like

Thanks for bringing this to our attention. I’ll share this with the product team more broadly to see if the latest updates are related.

1 Like

I am also seeing the delay in transactions downloading. Most noticeable with the Fidelity Investment accounts. And it definitely started after the update.

Same problem today. In fact, every day since the update. This needs to be fixed.

1 Like

Yeah, I don’t know what’s going on. None of my transactions filled yesterday, but then they magically showed up this morning. And Tiller seems to be choking a lot this morning. Forced me to log-in from scratch, which it never asks me to do. Then, I got an error message when I tried to fill my sheets after refreshing. ETA: And now the sidebar is just spinning when I asked it to fill my sheets.

I think I’m experiencing the same thing. I just refreshed all of my accounts and after using the Fill function it said 16 new balances/transactions were filled. In reality, only 10 were filled. It hasn’t been long enough to see if they’ll magically appear after a wait period, but I certainly hope they do. I’m already entering manual transactions for 3 accounts because my primary bank isn’t updating and I’m told it will likely take 4-6 weeks or longer for it to be fixed.
After seeing other members reference a Balance History Sheet that I didn’t know existed, I’ve now located it and will manually add my bank’s balances. However, being without automated transactions and not having my primary bank’s balances updated automatically for that long seems unreasonable and defeats the “one-stop shop” benefit of a paid subscription to Tiller. And yet, here we are.

Just to be clear: my accounts have been filling eventually, just not immediately as they used to. So, I’m seeing no need to manually add balances.

Thanks; I understood what you meant. I refreshed again a few minutes ago and the expected transactions from this morning finally filled. I’ll have to manually add balances (and transactions) for the foreseeable future because the feeds from my Andrews Federal Credit Union checking account, savings account, and credit card stopped working a week ago.
I’ve been satisfied with Tiller, but I’ve only used it for 4 months and I’ve discovered that the issue I’m having now is also broken for an untold number of others. I’m having flashbacks to Mint’s poor service model and wondering if I made a big mistake choosing Tiller. It’s no fault of Tiller’s support team; they’re just the intermediaries, but the estimated timeframe given for Yodlee to resolve the data feed issues is unreasonable.

We’ve investigating this issue.

Can folks just try waiting about 1-2 minutes after launching the add-on to fill the sheet and DON’T refreshing again on the Console?

We think it’s just that the UI is so much faster to launch that the transaction update hasn’t finished yet by the time you fill.

1 Like

I’ll try it tomorrow.

Good morning, @heather. My morning report: I refreshed my accounts, waited a full ten minutes, and then filled. And my transactions were there, so it seems as if there may be something to your theory.

I refreshed my accounts, then opened my sheet and then waited 10 minutes before opening and launching the Money Feeds extension. Both my transactions and balances loaded.

So Heather and her team seem to have identified the issue. But it still needs to be fixed. A user should not have to wait to launch Money Feeds. It defeats the whole purpose of the so-called upgrade.

Not so fast…I didn’t share your successes.

After refreshing my accounts in the console, I launched Money Feeds, waited 10 minutes, and launched Fill Sheets. I got a message that 6 updates were filled, however, z****ero transactions were added. Next I checked my Balance Sheet and found that 9 balances were updated there. What?? I then went directly to the account sites of the two institutions I was expecting to see transactions and each of them had one transaction that had posted on 4/16 yet didn’t get filled on my Transaction Sheet. So, not only do I now have to manually add the transactions from my primary bank’s 3 accounts, I also need to manually log into each of my other credit card sites to verify that Tiller did what it said it did. Not good.

You’re right, @larryc531, this “upgrade” needs to be fixed, and fast. Have you taken a look at the Institution Alerts? It’s mind-boggling.

@Rebecca.S your issue may be unrelated to the Tiller Money Feeds fill latency here. There are situations where with certain financial institutions the refresh will succeed, the balances will pull, but we can’t pull transactions. That’s an issue we would have to work with our data provider on and you need to write into our support team using the chat tool at to validate whether that is the issue or not.

To your point @larryc531 - we didn’t know that the update of the transactions in our database was slower because there was such a delay with launching Tiller Money Feeds. One improvement exposed another area of latency. It’s something we can strive to improve, but not something we’re likely to fix quickly.

The other thing is we didn’t cut the Tiller Money Feeds launch time from 20 minutes to 10 minutes, we cut it from maybe average of 12 seconds to maybe 5 seconds. I think that if you just wait a few seconds, not even a minute after launching it, the transactions should be there and ready to fill. But that’s also just a theory.

I’m going to test this hypothesis tomorrow. I tried ten minutes today. I’ll try fifteen seconds tomorrow. #science


Another thing i’m noticing is that, and maybe this’ll be fixed with what ever is causing the foreground issue is that I’ve have it on auto update so i don’t needed manually update. but since the GUI update it seems to be 1-2 days slower than previously; ie just tried the manual update and it populated up to the previous day. Not sure if this is if the pull data was past the cutoff for the auto populate, but
I just manually refreshed, and hopefully that gets it back on sync in the next couple days.

I have tried a bunch of times today with all of the different timing recommendations and still just end up with a blank tile when I launch Tiller.

Any updates or changes? Do I need to allow access or re install the extension?