Autocat Amount Equals not working (or I don't understand it)

I frequently have bank account transactions whose Description is always of the form Check #xxxx: Sh Draft, where xxxx is a four-digit number, and whose Amount is always -$60.00. I tried to create an Autocat rule to set the Category for these transactions. If I set the Amount Min and Amount Max cells for the rule to $60, the rule works fine. (I read that the Amount Min and Amount Max columns use absolute values.) However, if I clear Amount Min and Amount Max and instead set the Amount Equals cell to $60, the rule fails.

Am I doing something wrong here or is Amount Equals broken?


— Roger

It is working for me. I have two rules for my insurance, where if it’s greater than an amount it must be my home insurance, and if it’s less than an amount it must be my car insurance, and it has worked fine.

Thanks for replying. Are your rules using Amount Min/Max or Amount Equals?

— Roger

Since my amounts can be slightly different every time, I use Min and Max.

Min and Max are working for me, too. But Equals isn’t.

— Roger

Ah, gotcha, re-reading your post I see you’re questioning if the problem lies specifically with equals. Hopefully someone else is using that and can comment.

Just to follow up in case anyone else runs into this problem, the solution is to ensure that the Amount Equals column in the Autocat sheet is using a Number format such as Currency. Thanks to Tiller support for figuring this out.