Autocat won't process using "exact amount"

I’m having an issue with an Autocat that I’m setting up for a series of very specific, daily transactions. I need to use the amount (all the same amount), but it doesn’t process when I add that amount ($5) to the rule. If I change it and use $4.99 in the minimum amount column and $5.01 in the maximum amount column, it processes just fine. It has to be something easy that I’m missing?

Hi @Gracy,

It sounds like there may be a rounding error somewhere, either on the transaction amounts themselves, or when the AutoCat Rule Builder creates the rule. Can you verify there are no extra decimal places on any of the amounts when you click on the cell that would round up in the display, something like 4.999999 or 5.00001?

After reviewing the AutoCat documentation, I believe this is your answer. Can you give this a try?

Amount Ranges
Use the amount min and amount max columns to set the minimum and maximum for the amount that the rule should look for. Enter these as absolute values.
If you need an exact match, enter that amount into both the min and max columns. E.g. if you want to set up a rule for your mortgage check that’s consistent every month you can use the Description Contains “Check #” and then use the Amount range $1200 for both the min and max.

1 Like

Thank you - I will definitely give that a try today and report back. I’m not as familiar with Sheets as I am with Excel, so it takes a little bit more to poke around, but it sounds like it wasn’t something I did incorrectly. I had actually thought about using the exact amount in the min and max columns. I have more of those transactions to process and new ones come in each day, so it will be easy to test both ways.

I appreciate the help.

1 Like


I tried it again with another account that has the same type of daily transaction.

First I copied the exact same AutoCat rule with the min/max value since I knew it works, changing the particulars about the account. I then copied the format of the Max Value column to the Exact Value column, removed the amounts in the Min/Max columns and inserted the value only in the Exact Value column. It did not find any of the transactions with that method despite using the copied format for that column.

I then removed the Exact Value and put the exact amount ($5) in both the Min and Max Value columns and ran AutoCat and it captured all 96 outstanding transactions.

So as suspected there is something about that Exact Value column/formatting that is causing the error. Simply copying the format from the other columns did not resolve it. I don’t know enough about Sheets to figure it out, but the workaround is easy enough. Obviously, since they documented in the article they are aware and did attempt to resolve it and just decided that offering the workaround was a better option.

Either way, my problem is solved. Thank you.

1 Like

Glad to hear the min/max workaround solves the issue!

I’m glad you were able to figure this out, @cculber2 and @Gracy.

For the record, did you ever try creating an “Amount Equals” column? The documentation says this is for strings but I checked the code and it looks like it should work with numbers as well.

1 Like