Citi Not Letting me Upgrade/Update?

I’ve followed the directions at Known Data Feed Issues & Workarounds for Citi and still get an error. It says:

We’re sorry.
Your request has failed due to an internal error or server unavailability. Please try again later.

Anyone else getting this or know of something I can do to fix it?


that sucks. i upgraded the first day the notice went out. had one do over but then it was fine.

then, today, my update failed. and when i clicked on “connection” (on the console) i was taken through the whole upgrade thing again. but, it worked the first time without error. i wish i had a clue for you.

Thanks. I had to open a ticket and they’re taking a look.

@andrewteg I’m sure the team has already offered these suggestions via Chat, but for others who may come across this, I’ve put together a troubleshooting guide.

Thanks, off that is linked and I found that instead of step 3 “Add as a site you want to allow 3rd party cookies” I instead deleted all my cookies containing tiller and Citi and google and then started again from homepage and it worked and updated my Citi accounts after re-logging into everything. I used to have 2 Citi logins so perhaps that was the cause of the issue and deleting my Citi cookies would have been enough but I’m not sure and am just glad it’s working!