Consistent Errors - Google Sheets Tiller Add-In Login

Over the past few days I have been seeing consistent errors when logging in (better stated attempting to login) to the Tiller Money Feed Extension.

Specifically I am receiving a Bad Gateway (error 400) or a “The state token is invalid or has expired. Please try again.” error

For reference I am using a Macbook Air (OS 12.5) with Google Chrome (Version 109.0.5414.119 (Official Build)

I have attempted clearing cookies and cache which worked once, for a single login but has not worked again.

Any ideas from the community? Unfortunately this makes Tiller relatively useless.

The Bad Gateway (error 400) type of issue is usually a browser communication issue, as opposed to an application issue. Tech sites recommend clearing cache and restarting - but you have already tried that. I had that happen a few times several years ago on a different product and was able to resolve it by using a different browser for a few days. Later went back to Chrome and it has worked fine ever since. I’d give it a try on a different browser if you have one available.

I’d second @fehegner 's suggestion.

For no apparent reason, one day last week I couldn’t to login to the Admin Panel of my wireless router/gateway from the latest version of Chrome. It reported “This site can’t be reached” “Err-Connection Refused”

I thought I had a hardware problem and I spent quite a bit of time with the supplier trying to diagnose the problem to no avail.

For some reason, I decided to try logging in using Firefox. It worked immediately. Then, I tried Safari. Same thing. It worked. Clearing the cache in Chrome didn’t help. Perhaps the next release of Chrome will fix the problem.

Hi @kampholdings just to confirm you’re trying to log in to the Tiller Money Feeds add-on for Google Sheets and you’re using the following steps:

  1. Open Google Sheet
  2. Open Extensions menu at the top of the Google Sheet
  3. Choose Tiller Money Feeds from near the bottom of the Extensions list
  4. Choose Launch
  5. Click “Sign in to Tiller” in the sidebar

Are you seeing the 400 error right after clicking that or does the new tab open to allow you to choose your auth provider (Google vs Microsoft)?

If you’re able to choose the provider, does it show you the “you’re signed in message” ?

Just trying to understand at what point in the process you’re seeing the 400 error in the Tiller Money Feeds sidebar.