Etrade Accounts Not showing up

I am loving using Tiller, I have been a long time Personal Capital user and love the depth and flexibility Tiller provides so far .

One thing that seem to work seamlessly with Personal capital is not working in tiller integration.Part of my compensation is RSU which comes through Etrade. In Etrade I have two accounts with exactly the same number . One account if for the RSU and the second one if for personal trading. This is a standing practice with Etrade.
In personal capital when integrating with Etrade balances for both accounts will show up. In tiller only one account gets pulled .
As personal capital also uses Yoddlee to get the data. It confirms that the data is coming from etrade.
It looks like it is more to do with how Tiller may be filtering duplicate accounts with same Number. In this case the account will have the same number but different type. I tried both mine and my husband etrade and the same issue is on both accounts

:wave: @Sue, welcome!

I’d recommend reaching out to our support team via the chat window in the lower right corner of the Console at

We may be able to work with Yodlee to get the other account pulled in.

Sent the message. I do not think it is yoddllee issue as it worked with personal capital.
This may be an issue of tiller filtering the data based on account # the two accounts will have the same account # but may be different type

@Sue there is a separate issue for stock plans from E*Trade - when you search in the add accounts screen try the other options that indicates it’s for stock plans

1 Like

i have this same issue. i added my account via the E Trade Employee Stock selection. did OP get this figured out?

Are you trying the “Stock plans” option?

1 Like

yes, that is the option I choose. I am thinking it is because the current value is zero and i was looking at the "potential balance" when they vest. Is that right? Can it show the potential value or does it focus on actual vested amounts?