FIXED! Yearly Budget showing #VALUE! error instead of year

I’m getting an error on my Yearly Budget Report. It says, “Error: Function YEAR parameter 1 expects number values. But ‘Hide From Reports’ is a text and cannot be coerced to a number.”

For some backstory, I had been getting #NA errors all across both my Monthly and Yearly Budget spreadsheets. I dug around and saw this thread that mentioned adding “Tags” to the Categories sheet could have caused the issue.

I tried moving the “Tags” column to the very end of the Category sheet, which the other user had mentioned working, but that didn’t fix it, so I pressed “Undo” to move the Tags column back to where it originally was (between Type and Hide from Reports). Then I tried using Tiller’s add-ons to “Restore Sheet” for both the Monthly and Yearly Budget. Sure enough, that fixed the #NA errors on both of them (so there appears to still be a glitch with adding “Tags” to Categories).

However, now I have a new error on my Yearly Budget sheet. At the top everywhere the year should be, it now just says #VALUE!

I’m assuming it has something to do with attempting to move the Tags column (even though I pressed Undo), and now the Yearly Budget is for some reason trying to reference the Hide From Reports column for the year??

Never mind – FIXED IT! This was possibly one of the most embarrassingly easy fixes. For whatever reason when I reset the Yearly Budget, it showed the VALUE#! error instead of auto-setting it to 2021. When I clicked on the down arrow below “Budget Year View” it gave me the option to click on 2021. When I did, all of the errors went away.


Glad you figured this out @caryupnorth!

Most of the time if restoring a solution using the Tiller Community Solutions (TCS) add-on doesn’t work the issue is that a header in either Categories or Transactions is missing or misspelled. Or a tab that one of those budget sheets relies on has been re-named.

The FAQ here details common issues/fixes.

1 Like