Google Sheets Foundation Template not updating

The last two days, I have been trying (without success) to update my Google Sheets Foundation Template.

I do my normal workflow: Open my Google Sheets Foundation Template > click Add Ons > Tiller Money Solutions > Launch Sidebar > Fill Sheets. However, after I click “Fill Sheets”, I get stuck in the view where the thinking bubbles are running and it says “Loading new balances and transactions.” I’ve waited 20-30 minutes each time the last few days, and it just stays in that loading phase while no new transactions show up and none of my balances get updated.

I’ve logged into my account and all of my accounts have refreshed within the last day.

How do I get transactions and balances to start updating again in my Google Sheets Foundation Template? I’m really hoping I don’t need to create a new Google Sheet and downloading all of my 2021 expenses again… (I create a new sheet for each calendar year).

Thanks in advance for anyone who can help!

Hi @eilean:

I have had this experience on occasion.

Does the processing dialogue ever complete and return the message that no new transactions were available or does it seem endless?

Here is a great post that may help.

And/or try this:

  1. On the Tiller Money Feeds Sidebar, click, “Settings.”
  2. Click, “Logout,” then click, “OK” to close the logout dialogue that appears.
  3. You are now logged out of Tiller.
  4. Close your browser, too.
  5. Open up Chrome.
  6. Open the Tiller Login Page.
  7. Open up your sheet.
  8. After the Add ons load, Select Tiller Money Feeds and follow the prompts to log back into Tiller and initiate the download.

Working without a net here, but hoping this may help… :grin:

If this doesn’t resolve your issue, reach out to technical support (the chat bot in the lower, right-hand area of the console or sidebar) and see if they can look under the hood of your spreadsheet and set things right.

Does this help?


Can you please make sure you’re not signed in to other Google Accounts in the browser? Try an incognito browser session or a dedicated Google Chrome profile.

Read more on how to set up a distinct browser profile in Google Chrome here:

Let me know if that doesn’t help.


1 Like

I’m having the same issue, I have been unable to use the spreadsheet at all today because it is stuck loading. The progress bar in the top right reaches about 90% and then stops, the Tiller side bar won’t load, and there is a “Working” popup at the bottom of the screen that never go away.

I tried the sign out/sign in that Brad suggested, but, after sign in, the side bar shows a “Get Started” button and when I click, nothing happens and the “Working” popup is spinning at the bottom.

Edit: Just got a red bar that says “Exceeded Maximum Execution Time”

I’m guessing there’s some issue with Tiller services, because I’m also seeing the same thing. Unable to fill sheets.

Also running into the same issue…

Thanks everyone for the suggestions!

Heather’s solution worked for me. I was logged into my work Google profile on my Google Chrome browser. When I switched my Google Chrome profile to my personal Google profile (which matches my Tiller account), all the missing transactions from the last few days appear to have all loaded.

1 Like

was able to get it working this morning with the separate chrome profile… thx.

Glad to hear the separate Chrome profile worked for you @viachicago and @eilean. Definitely try this if you haven’t already @pippin and @ryanfowler88! We’re working to address this issue so it’s more intuitive right in the add-on that you’re signed in to multiple users in the browser. Sorry for the inconvenience.

Yup, looks like that was it thanks! Looks like a new Chrome change to how they do profile is causing many folks to see this.

I have only one profile - never have had more or different than this one. And, yet, I am experiencing all the issues described above. I have logged in and out of chrome. Done a hardware reset on my chromebook. No change. Still unable to update my accounts in the spreadsheet.

I’ll keep checking back for updates.

EDIT: 3 hours later, did not reboot or refresh anything. Just hit the ‘fill sheets’ again and all filled in properly.

Same. Had to manually click fill sheet and finally some accounts filled in.
PayPal is still not updating.
Meanwhile, I’m getting the daily updates so I didn’t even realize the sheet wasn’t been filled.