Tiller Foundation Template & Tiller Money Feeds extensions not working

I’ve been noticing the last few weeks that the Foundation template and Money feed extensions have not been functioning correctly. I’ve hit reload and nothing seems to jar the template or money feed extensions. Do I start a new template? Do I start deleting data from older transaction (previous years)??
Something seems off on the template and money feed extensions…anyone else experiencing this issue?

I am also experiencing Money Feeds not loading properly. The header loads, but nothing else. I tried an incognito window and rebooting and neither helped.

You can add me to the list of Money Feeds not loading properly with Google sheets.

Added that Extension Fill not working with google sheets.

I’m still experiencing this since yesterday. the extension launches but the contents within it is blank

I cleared my cache from Chrome (all cookies) and now it works. Had to Launch first before selecting the “Fill Data” option.

We’ve posted the solution over in this topic.