Robinhood no longer supported?

After a few weeks away, I recently updated my Tiller sheet and discovered Robinhood won’t sync anymore. It gives an error of Site Not Supported and the Last Refresh was listed as Never. I deleted the account and tried to re-add it, but it still gives the same Site Not Supported error.
Is anyone else seeing this issue?

I know mine wasn’t syncing for a while, but I was able to sync it yesterday. I just refreshed now, and I got the “Site Not Supported” error. The Institution Outages sheet shows Robinhood having an issue that started 10/6/21, and the tentative ETA for having it fixed is 12/16/21. Fingers crossed that’s somewhat accurate…

Aha, I didn’t know about that outages sheet! That’s very helpful, thank you!

Yeah I was surprised to see the Site Not Supported message as well. I checked the Institution Outages sheet as well but this doesn’t appear to be an outage to me, it seems the issue is on Tiller’s side. Also, I have updated my Robinhood account via Tiller just about everyday and that error just started showing up 2-3 days ago. Would love to hear an update on it from Tiller if possible!

This is the response I received from Robinhood - to which I responded it was unacceptable given other institutions use of TFA and other means to allow connection:
I reached out for some clarification regarding connecting your Robinhood account to Yodlee/Tiller.

Account security is really important to us, and we’ve recently made some changes to the Robinhood app to help us protect our customers. These changes prevent some 3rd party services from connecting to Robinhood accounts.

I know this is not the answer you were hoping for, but your account security is our priority and we’ve decided to make this change to further protect the Robinhood community.

While we may revisit allowing third party logins in the future, we ask that in the meantime, you consider our recommendations on security best practices to keep your account secure.

Sometimes it’s a false negative on the “Site not supported” error.

Can you see if these steps help?

  1. Log in to the Console at
  2. Scroll down to the Account Summary section
  3. Choose Add accounts
  4. Add the account as if you were adding it for the first time

Please do NOT remove the account as a troubleshooting step.

@heather Did you mean ‘do NOT remove the account as a troubleshooting step’?

er, yea :woman_facepalming: - do NOT remove

Looks like it’s on the outage list now with an ETA of 12/21

Sadly I already tried removing and re-adding the account before I posted here. :frowning:

@heather I tried the workflow that you described above and still got the same “Site Not Supported” message.

hi @ryanstraits,

Sorry that didn’t work. It’s a bit hit or miss. Usually this means that the institution is blocking Yodlee’s IP addresses, but that’s also in conflict with the site alert description “User action required”

Please review the action next steps here:

This needs to go through our support team so after following those steps reach out to the team via the chat tool on the console at to continue troubleshooting.

I’d also recommend calling and complaining to Robinhood directly about this issue as it’s likely going to be escalated at Yodlee that they’ll have to negotiate directly with Robinhood to resume support.


Thanks Heather! So I just tried to run Robinhood on the Tiller Dashboard and it connected! So it looks like it’s back up & running.

Thanks, @ryanstraits. It could also just be intermittent :woman_shrugging:

I was able to update Robinhood today.

We heard back from our data provider and they indicate that Robinhood recently implemented a puzzle style MFA, which is difficult to support. I believe they are working on a way to “solve” the puzzle, but not sure how that’s going to go.