Ally Bank not syncing

Tiller Feeds is working fine for two of my connected banks, but Ally Bank hasn’t synced for 6 days.

Help!? :flushed:

:pray::nerd_face:

My Ally bank isn’t syncing either. I tried re-linking the account from the Tiller Console, but it just gave me a “We’re experiencing technical difficulties”. Sounds like this issue is on Yodlee’s side, not Tiller.

Our data provider is currently having an outage with Ally Bank. The listed ETA is still 1/20 and we do not have an updated ETA from them on this yet. You can monitor and track the outage here.

Hi @heather (or other Tiller rep),

Thanks for the quick response the other day. Unfortunately, I now see that the ETA for fixing Ally has changed from 1/20 to 1/31. Having my primary bank unable to sync transactions drops Tiller’s utility from :100: to :zero:, which is kind of a big deal.

I understand you guys don’t have direct control over the situation, but an endlessly-shifting ETA leaves me feeling somewhat despondent for my ability to trust Tiller in the long run. (Basically, I’m praying that I won’t have to fall back into the arms of the Intuit beast!)

Can you please explain a bit more about what’s going on here? Having now invested many hours into integrating Tiller into my financial life, I’m interested not only in when the issue will get fixed, but also in what has caused the issue in the first place, what risk there is of it occurring again, and what Tiller is doing to address that risk.

This has got to be frustrating for you as well, so hopefully this request isn’t stressing you out. I really appreciate how responsive you’ve been with my questions thus far!

You guys rock. :slight_smile:

3 Likes

You can simply download the transactions directly from Ally and copy and paste them into the transactions sheet.

Interesting idea, @xlengthy. Two thoughts come to mind…

  1. Won’t that result in my having to remove duplicates once automatic syncing starts working again?
  2. Even if Tiller’s magical enough to avoid creating duplicates, I’d still like to understand what’s going on in order to get a sense of whether this is likely to happen on a regular basis. Automatic transaction import is basically the only feature I was seeking when I found Tiller, so… ¯\_(ツ)_/¯

Regardless, I appreciate you pointing out the workaround! Along with the stellar support from folks like Heather, I’m liking the community here. I’ll take your idea under consideration…after a good night’s sleep. :relieved::zzz:

Appreciate all the info here. I’m having the same issue, and just noticed this thread. I’d agree with everything @clozach has both said and requested. I’m also interested in getting some answers to the questions he’s already posed.

@clozach,

Yes, when the feed resumes, it’s likely that they’ll pull in the gap of data since the last feed and you’d end up with duplicate transactions.

If that’s the case you’ll be able to easily identify them because the automated ones will have a transaction ID and your manual ones will not.

I can’t say whether it’s something that is likely to happen on a regular basis. Ally has been on the outage list once before early last year if my memory serves me correctly.

The issue usually happens when the bank changes some aspect of the website layout or authentication measures and our data provider has to reactively update the integration to handle the changes.

Hopefully that helps shed some light on things.

Heather

Thanks, Heather.

This does help a bit. Not that this is a test, but using that as a metaphor…for full marks, there’s still one question unanswered: What is Tiller doing to address this risk?

I’ve been around enough to expect this could be a challenging question. I’m sure you don’t have the resources of Intuit, and I know that the financial world is complicated, not least because you’re operating in a heavily-regulated environment. Still I wonder, do you have plans to, at some point, build in some redundancy with your provider, or potentially have a backup integration in place with another provider? Could you be working with someone whose turnaround for these fixes is measured in days or hours rather than weeks?

Again, I know this is a tight spot for you guys, but I’m hoping you can follow in the footsteps of other companies I’ve seen which, in response to a data outage, have published a summary of the issue and steps in place to reduce or eliminate the future impact of similar outages. Even if it takes awhile to get this airtight, one hopes that the plan goes beyond, “It’s out of our hands. 🤷”

(Hope I’m not coming across too pushy…though I probably am. :grimacing: All of my feedback comes from a place of wanting to be able to recommend Tiller so enthusiastically that everyone I know makes the switch! We’re just not there yet. :upside_down_face:)

2 Likes

I’m having the same issue and just found this thread. Thanks to clozach for raising this and to Heather for keeping us Ally users updated. For me Tiller is “broken” until this gets resolved.

3 Likes

We do hope to build in redundancy in the future, but it’s likely a very long way out. We’re still trying to make sure our implementation of the integration with our primary data provider is rock solid, despite their outages with specific institutions. We upgraded the integration to use a new API about a year ago, and still working to ensure that’s the best it can possibly be.

Thanks for your patience and understanding. :wink:

1 Like

Is there any new information on this front? My accounts don’t seem to be updating, so I imagine this is still down?

1 Like

I stumbled upon this page as I am having the same issue with Ally feed using a competitor
product. The issue is apparently with the feed service Yodlee. I was also told that it would be fixed 1/31 per a Yodlee release, but at this time mine is still broke. The error I receive is, “Feed sync error (426) - could not be synced due…”. Very frustrating.

Will there be an update today one way or the other? I know those of us who’ve been affected have probably had 1/31 circled on our respective calendars for a little while now.

3 Likes

20 days and counting. That’s far past half the month without being able to actually use the service, 4 days past the already-revised estimate. Given that the new ETA is still several days off, I respectfully request a 1-month refund.

Is there a way to directly express our displeasure to Yodlee? And/or Ally? While on the one hand this is certainly a First World Problem™, it’s a pretty poor showing for a well-established data company like Yodlee and a well-established online bank like Ally. (I’m also a little ticked on your behalf…their lack of movement here reflects badly on you, which is hardly fair!) :pouting_cat:

Lovingly frustrated,
Chris

3 Likes

It’s Yodlee. I added my Ally account to Mint and it worked fine. I was also given a new 2/7 “fix” date. Ridiculous.

Is there a way to update balances manually? I can wait on transactions but use the Balances sheet for other things and would like to be able to update that, but changing the values in either or both of the visible column (under Assets) or the hidden column (under Sorted Assets) creates an error.

If there is a trick to updating balances, could you share so I can keep that on track?

I have a few accounts that I have to update manually now (Yodlee is really dropping the ball on some of these…) and what I’ll do is just create a new row in the Balance History sheet and copy and paste the last entry that was automatically added in order to get the correct Institution Name and other data. Then I update the Date, Amount, Week, and Month. That usually takes care of it!

Hi @andrewteg,

@Darin has the right answer here. A few more bits of info:

  1. Balance History is usually hidden by default. Open the View menu > Hidden Sheets to unhide it.
  2. Make sure you’re using the exact same Account ID (possibly a hidden column) for the new entries for Ally to ensure it doesn’t get picked up as a second instance of the account.

Very frustrating it is taking so long. It is even more frustrating when it spans over the closing of a month, regardless, this should have been corrected by now, 2 weeks and counting.