Simple Business Dashboard not showing Tiller Balance

Hi

My Simple Business Dashboard only shows Bank balances but not Tiller balances for each account. Restoring the Dashboard has not helped. Note that there is a difference between columns allocated to the two vertical sections in your Comprehensive Guide and My Simple Business Dashboard:

                                              Comprehensive Guide               My Sheet

Tiller Money Columns A to J Columns A to H
Simple Business Dashboard Columns K to V Columns I to T

It seems that the Dashboard part is covering up 2 columns where Tiller balances would be shown.

Anil Parikh

@anilparikh1

Please see below.

Thanks,

Blake


Account Balances

Current account balances are displayed list in the sidebar’s bottom-left corner. This data is pulled from the Accounts and Transactions sheets. This section is the only section without its own dropdown period selector.

image

Two balances are shown for each account— Tiller and Bank.

Bank Balance

The Bank balance is the last available balance for the account from the Accounts sheet.

Tiller Balance

The Tiller balance is calculated based on the latest balance history entry for the account and also any uncleared/manual transactions you may have manually entered that are waiting to be reconciled. If your spreadsheet does not include any unreconciled manual transactions, the Tiller balance is not shown.

Blake

Let me clarify. Please look at the snapshot I included. I do see balances but only from my Bank. Tiller balances are missing. I tried to widen the column containing Bank balances but that does not show Tiller as it is in adjacent column I. As I see it, Income and Expense pie charts should begin at column K (same as in your Business Dashboard write-up), so that Tiller balances show up under Balances in column I and J. In my sheet these pie charts start in column I so Tiller Balances are covered up.

Anil

@anilparikh1 @randy

Please see the discussion thread at the end of the link below.

Sorry, but I should have elaborated in my prior post. I understood your initial post. The new dashboard was designed to show the Tiller balance column only when it differs from the Bank balance column. You do not have any differences so it does not show. If you add an uncleared/unreconciled manual transaction, then the Tiller column will appear since there will be a difference. Short of this, the only way you will get that Tiller column to show is to reprogram/redesign the dashboard yourself.

Does this answer your concerns?

Thanks,

Blake

Blake

Thanks for clarifying. May I then suggest that Tiller article on this subject is revised to reflect this. The illustration in the article shows Tiller balances as well.

Anil

I can see the cause for confusion, @anilparikh1.

The forum-documentation says: “If your spreadsheet does not include any unreconciled manual transactions, the Tiller balance is not shown.” … but perhaps this is too buried.

I wrote the dashboard to hide the Tiller balance if there wasn’t a difference because I thought the Tiller balance would be confusing to (the majority of?) users who don’t use manual balances.

There is a formula in E20 that looks like this: =if(countif($AV$3:$AV,"<>0"),ARRAYFORMULA(IFERROR(VLOOKUP(row($AO3:$AO103)-Row($AO$3), {$AP$3:$AP, $AW$3:$AW}, 2, FALSE), iferror(1/0))),iferror(1/0))

If you want to make the Tiller column always present, just remove the initial IF statement. (Though I think there may be a bug— identified in another thread—in this formula that I need to fix this week… so you may have to make this change again soon.)

Good luck,
Randy

Thanks Randy. I like to see both balances. So I will wait till you have fixed the bug before removing IF statement.

The great thing about Tiller is that you can always restore the default sheet anytime if one does not like the changes made.

Anil

I’m glad to hear you appreciate our version-management and restore tools, @anilparikh1. :smiley:

I just updated the formula in the business-template master. Please use the Manage Solutions pane in the Tiller Labs add-on to update your sheets to version 2.02.

Also, based on your feedback, I added a hidden configuration control to always show Tiller balances (without changing formulas). If you’d like to change this setting, unhide all the hidden columns on the right side of the sheet and change cell BB24 to TRUE. (You will need to reimplement this setting-change whenever you restore or upgrade this sheet.)

Hope this helps.
Randy

@randy ,

Great idea. However, I might suggest adding that control out in the main viewing area, possibly at cell A17 and then explaining what is does in your written documentation. I suspect more people than you think might want to see both columns even if they are usually always identical.

Thanks,

Blake

Thanks for the feedback, @blake. My guess is that many users won’t use the manual transactions workflows. My concern is that, for most users, the “Tiller balance” will be a point of confusion.

If we get feedback (in this community) that the (sometimes) hidden column is confusing, I agree that we should make the setting more visible.

Randy

@randy

In the old version of the dashboard, how many customers complained about being confused by seeing both columns when that was the default presentation? Any? This impacts old users who were used to seeing both but now only seeing one. New users never saw the old version. This is a frame of reference issue.

Thanks,

Blake

I just published an update to the Business Dashboard, @blake, and took your suggestion to heart. The default view is now to show both columns (even if there are no local/manual balances). The default can be changed in the hidden area still.

Randy

1 Like

@randy , I just updated. Nice. I think you will get less questions this way. Blake

There is a new update to the Business Dashboard that better respects (and removes) transactions from hidden Categories. You can get the update from the Tiller Labs add-on and then use Manage Solutions to Upgrade the Sheet.

@jonorlin

So, whatever you hide on the categories tab will not appear on business dashboard tab, right?

So, if a user has both personal and business categories in their sheet, then their dashboard can show three views all by manipulating the hide function on the categories tab, right? ( personal only, business only, and both).

Blake

Hi @Blake,
Yes. If a Category is set to Hide on the categories sheet sheet, its transactions won’t be included on the Business Dashboard.

So if you set the Categories sheet to hide all business, or hide all personal, or don’t have anything set to hide, the dashboard would update to reflect each of those preferences.

That’s seems like a lot of changes to make each time. But I guess you could create separate columns for different category Hide settings, and then copy them into the “Hide From Reports” column.

I haven’t tried this but instead of copying them into that column, you might be able to name the active column you want to use as “Hide From Reports” in Row 1 and give the other columns a different name in Row 1. The Business Dashboard looks for a column called “Hide From Reports”, but there should only be one of them at a time.