Simple Column Filter - not working on some columns

I’m using foundation template and google sheets.

I can successfully apply a filter on Column F - Group, but not working for me on Column C - Description.

It’s like the column is read only or something…I can’t figure it out.

Does the upside down triangle ‘filter’ symbol show up on column C when you turn on filtering? Have you tried first selecting the entire sheet by licking on the cell above ‘1’ and to the left of ‘A’, then turning on the filter?

Here’s a handy reference for how to turn on the filter in the entire sheet as @jpfieber describes.

Thank you for offering suggestions on my filtering issue. The filters worked on some columns, but not all…it was very strange. I believe the range of cells got messed up when I added a few thousand rows. Solution - I deleted filter views and adjusted range and filters started working as expected on all columns.

(To prevent this in the future, never add rows at the bottom of the sheet, only in between rows that are already within the filter view’s range.)