Tiller Money Feeds Add-on Spinning and Won't Update in Google Sheets

When I launch the Tiller Money Feeds extension in Google Sheets, the Status icon keeps spinning and nothing else happens. I uninstalled and reinstalled the extension but that didnt solve the problem. I also restarted my computer. I’ve been using Tiller for 6 months and have never had an issue. Does anyone know how to fix this so that I can update my transactions? Thank you so much!

Have you tried using a different browser? Not a real fix, but maybe it will get you up and running.

Is the browser up-to-date?


Yes, its up to date. I tried in incognito mode in both Chrome and Edge, and it didnt work there either. Appreciate the help!

Try File > Make a copy and see if it works in the copy.

Just tried that and it didnt work either. Any other suggestions?

Are you launching it via Extensions > Tiller Money Feeds?
(not Extensions > Add-ons)

Maybe try linking a new spreadsheet, and check it there, just to see if it’s something specific to that spreadsheet or more general to your system.

By any chance have you added or changed a browser extension restricting pop-ups? I did this the other day testing out a browser extension for pop-ups. It messed up my browser access to Tiller Money. I had two options; remove the extension or add Tiller Money URL’s to exclude. The exclude worked but I ended up removing the extension. I didn’t want to deal with exclusions for other websites I use.

Sorry for the delay! I’m launching via Extensions>Tiller Money Feeds.

How do you link a new spreadsheet?

@Clint. I didnt install or change extensions; however, I did just disable all of my extensions, restarted my browser, and the problem persists. Any other suggestions? Thanks for your help!

@Mark S. I figured out to link a new spreadsheet and the Tiller Money Feeds extension doesnt work on that one either

It sounds like it’s maybe something with your PC, since it does not depend on the spreadsheet.

New VPN or firewall or anything else new? Windows or Mac? Work or home PC? Can you try it from a different PC? And I’m guessing you don’t want to reinstall the OS. It’s just a guessing game :thinking:

Might need to contact support via the Tiller Console for this one.

BTW, this is not me, I’m @Mark.S … easy to do, no worries, just letting you know.

I’ve been using it on a work PC. I just tried it on my wife’s Mac and it’s not working there either.

We have this issue via our internal support channel already so we’ll take it from there and try to update this topic when we figure out the issue.