4/29/2021 - Tiller Money Feeds Stopped Updating and I get a Type Error

The “Updating Transactions and Balances” seems to be on an infinite loop and then I get the error “TypeError: Cannot read property “length” from undefined.” After this the sidebar disappears and every time I try to reopen it again I get the TypeError…

I have cleared the cache, tried signing out (where I get the same error and am not able to sign in again, and then I installed and reinstalled the add-on which allowed me to sign in again, but then the process repeats…


What did I screw up?

1 Like

I just got the same thing this morning.

Same. This has been an issue since around 6p ET.

Also, if you sign-out and then click the sign-in on the Money Feeds sidebar, you get:
TypeError: Cannot read property “length” from undefined. (line 1050, file “src/infrastructure/auth/TillerAPI”, project “Tiller Money Feeds”)

I have the same issue, thanks for posting this.

We’re investigating and working on a fix! Thanks for the alert here :slight_smile:

2 Likes

Same issue - following.

We have identified the root cause. Customers who had previously linked an account to the sheet and then later removed the account entirely from our service via the Console > Account summary are experiencing this issue.

For some reason the add-on thinks that deleted account is still linked to the sheet and when it tries to update it can’t find it anymore.

We’re working on a fix and hope to have it pushed out soon.

1 Like

We’re also receiving reports that accounts that were previously not linked to a sheet are now appearing as linked to a sheet and customers cannot remove the link and we believe this is related to the same underlying issue.

1 Like

I just want to say that the popup about this on the Tiler Money Feeds addon modal was really nice. Thank you so much!

3 Likes

Okay, we pushed a fix out so believe this should be working again now.

Fixed for me, thank you!

1 Like

Can confirm that this issue is now fixed for me. Thanks Heather.

1 Like

Fixed for me as well. Thanks.

1 Like

Glad to hear this is working for many of you now!

I should note that due to this :point_up: issue Tiller Money Feeds might have added transactions and balances for accounts that were not actively linked (we aren’t sure if they might have been previously linked but unliked later). The best recommendation is to restore your sheet to the version just prior to the update that added the unlinked accounts’ data and then update your sheet using Tiller Money Feeds again and it should pick up where it left off without re-introducing that data you didn’t want in there.

1 Like

This is what I did. Worked perfectly!

I noticed this issue earlier this afternoon as well and thought it had something to do with the most recent Chrome update or the fact that Chrome, all of the sudden, started asking me which profile I wanted to use. I just checked and it’s back up and working as expected. Thanks to everyone who got this resolved so quickly!

Thanks, fixed for me as well.

Working now! Thanks for the quick response!

Old transactions from a no-longer linked account were imported again this morning. – OOPS – seems I was looking at transactions from a couple of days ago before the problem was fixed.

I reached out to John directly via support channel & it was false alarm :relieved: