AutoCat category dropdown just says "loading..."

I am having issues with my AutoCat dropdown not populating. For Example, I started a new template for 2023 and have been filling my budgets and data. On the AutoCat tab, I’m adding some new items to categorize for me. In the dropdown for Categories, my list is not populating. It simply says Loading. It will not let me select a category for coding. However, if I manually type it in or copy from another line, it works fine. I’m just trying to understand why my list won’t show and allow me to scroll and select the option I want.

Hi @nmfrisina - are you using Google Sheets or Excel?

Generally in Google Sheets if it just says “loading” it’s because the data validation rule is broken in the cell. Might be best to rename your AutoCat sheet and then re-install AutoCat and then paste special > values only to page your rules into the fresh AutoCat sheet.

Hi @heather ,

I’m using Google Sheets. I renamed the AutoCat sheet and then tried reinstalling AutoCat and it seems to be in a perpetual state of installing. You see the circles moving back and forth but then nothing happens. Additionally, it overwrote the renamed AutoCat sheet and now only shows a Tiller’s subscription rule and all of my other rules were removed. I was able to reinstall an old version of the file so I haven’t lost it but I can’t understand how to rename and reinstall without having this issue.

I don’t know if this has anything to do with this. I’ve been using Tiller for 3-4 years now and I was having some issues with my other file. So I followed the instructions to create a new template for just 2023 activity. I don’t remember if I did a paste value for AutoCat when bringing over the rules from my other file. Is there another way to go about this? Is there something I’m doing wrong?

Hi @nmfrisina I’m sorry for the confusion here. I assumed those steps would work without testing them. I feel like that’s how they used to work, but I could be misremembering or something changed after we implemented our “templates” feature in Tiller Money Feeds.

It sounds like you restored to a prior version to revert back.

I just tested it and it looks like you can right click and “duplicate” the AutoCat sheet, which will add a sheet “copy of AutoCat” so you have your rules, then delete the original AutoCat sheet and re-run the install. Then you can copy the AutoCat rules from the “Copy of AutoCat” sheet and Paste special > values only into the new AutoCat sheet.

If you’re still experiencing the dropdown menu issue after that, it could be that a column name or column it’s expecting is missing or the Transactions sheet or Categories sheet or one was renamed. Can you double check that the Transactions sheet is called Transactions and the Categories sheet is call Categories and that there aren’t any missing (blank) header keywords in row 1 on the Categories sheet and the Transactions sheet? If any of the headers are misspelled that could cause issues

You can access a view only version of the Foundation Template here to compare your headers: