Envelope Budget Scripts Not Working - adjust cell and dropdowns stuck

I am using the Tiller Budget Template (not Foundation Template). The scripts seems to have stopped working on my Monthly Budget tab. I was able to put my budget amounts in at the beginning of June, but since then the scripts have seemed to stop working on that tab. Transactions are updating and when categorized the scripts run, but I cannot make any adjustments to the budget numbers, using the ‘b=/+’ shortcuts or switch to previous month’s budgets from the drop downs in the upper right corner. Not sure what happened in the last week. I tried doing a restore on the tab, but that didn’t work either. Anything else I can try to get them to start working again???

Thanks for the help.

1 Like

@randy any advice you can add.

That is troubling, @matthew.fuller526. You might try uninstalling the Tiller add-on and reinstalling it. The add-on contains onEdit() “triggers” that fire and process the spreadsheet whenever you type. I’m hoping that those triggers will be reinstalled when you re-add the add-on. (I haven’t seen that behavoir before.)

@warren Thanks for the bump to Randy

@randy Tried the Tiller and Money Feeds add ons, no luck. I wouldn’t think Labs would change it right??

I’ve been wracking (racking??? wrecking??? I am a math guy not and english guy.) my brain to see if there was anything else I may have changed in that time frame that would have caused any problems, and I can’t think of anything. I am not sure I even opened the spreadsheet during that time. It is also weird, to me at least, that it works when I categorize on the Transactions tab but not on Monthly Budget.

@matthew.fuller526, I think you just need to run Analyze Budgets History under the Envelope Budget add-ons menu and that should fix the adjust values getting stuck and the drop downs not working.

Add-ons > Tiller > Envelope Budget > Adjust Budgets History

I had this issue before, I had modified some of the formulas in the “Monthly Budget” sheet and when I reverted them it worked correctly again.

@heather Thanks Heather!!! That seems to have done the trick. I appreciate the help.

My Monthly Budget sheet is not auto-populating the Budget numbers I set in my Categories sheet. There is a #REF! at the top. However the Actual Expenses do populate just fine. Having the same issue on my Yearly Budget sheet the Income Budget is not auto-populating. However the Expense Budget populates fine on the yearly budget sheet. I’m just entering back into this after a few months and am novice. I don’t know if I have the Tiller Budget Template or Foundation Template? I do have the Tiller Money Feeds add-on. It seems like these scripts were erased or no longer work for these budget sheets to populate. Could there be an easy fix?? I don’t want to tinker and lose the work especially the hundreds of transactions I have categorized manually. Any suggestions??

Hi @Tiscione, it sounds like you’re using the Foundation template (the envelope budget via the Tiller add-on doesn’t have the budget months in the Categories sheet).

I’d recommend restoring the Monthly Budget sheet using the Tiller Money Labs add-on.

Hi, I am reporting that today the adjust cells have stopped working for me. Unsure if I accidentally altered something else in the sheet prior but I have not experienced this issue before. Tried restoring the dashboard and analyzing the budget history a number of times to no avail as well as reinstalling the Envelope Budget add-on. The adjust column either doesn’t update the sheet at all or takes an extremely long time.

If it’s taking a long time it could be due to the amount of data or other dashboards in your sheet. Did you also install other sheets via the Tiller Money Labs add-on?

That Envelope Budget add-on and associated scripts are notoriously slow/not performant.

You might want to check out the Savings Budget sheet as an envelope budgeting alternative if you are okay with a monthly budget period vs bi-weekly or weekly.

I have only installed the Category Tracker.

Regarding the Savings Budget sheet- I’ve been using the Envelope Budget sheet for about a month and am comfortable with its functionality so far. Are there any plans to deprecate it in the far (or near) future? And if so, are there any migration tools available to move my data from the Envelope Budget sheet to the new one?

There isn’t a plan right now for deprecation, but we aren’t making improvements/really maintaining the envelope budget.

You can migrate your transactions/categories/AutoCat rules using this tool: How To Use The Migration Helper From Tiller Labs

And more on migrating budget history here:

1 Like