Feedback & Bugs for Tiller Labs Add-on

Please share your feedback or bugs you encounter by replying to this topic.

Thanks!

The “learn more” and “report and issue” links from the help menu for the Tiller Labs add-on both lead here, which doesn’t exist: https://community.tillerhq.com/c/labs/solutions

Things are coming together quickly with the new add-on and we’ve still got a few loose ends. I’ll have a fix published to this in a few days.

Good catch, @thromer.
Randy

Hi,

I just used the add-on to manage and update the Accounts sheet to version 2.0. I made a copy before the update, completed the update and it was blank and never auto-updated. From reading here, it seems like I should now copy my data from the original copy to the updated Accounts sheet. Is this correct? Is the feed not updating the sheet on refresh or tied to some hidden process like the older sheets? Just curious.

It would also be nice if the info about current tab would give instructions before doing the update and having to come here to figure out what to do so the user stays in one place and knows ahead of time the steps necessary to update/restore.

I’m glad to hear you’re using this new tool, @Nakeva.

Can you clarify…

  1. Are you using Tiller Feeds?
  2. Is the sheet you upgraded our recently-released Accounts sheet? I.e. was it created in the past few weeks?
  3. When you say “it was blank and never auto-updated”… are you referring to columns A-D on the Accounts sheet?

Generally speaking, the Accounts sheet serves two purposes:

  1. It allows you to optionally override account classes + apply groups & hide settings to downstream sheets.
  2. It consolidates account information used by downstream sheets (like Balances)

Adding data for purpose 1) is optional. If you had added information to columns A-D the sheet you backed up, you should copy those fields (columns A-D) into the new sheet.

I hope this helps,
Randy

1 Like

Hi @randy!

I am using the new Tiller Foundations Template with the new Tiller Feeds add-on and new Tiller Labs add-on. I think I expected the Accounts sheet to update but leave the data setup. I figured out it updates and leaves it blank then you copy your data back in or go through setting up each account using the drop-downs in the cells. Since I made a copy before upgrading the Accounts sheet to v2.0, I copied over the setup and it started populating the Balances sheet.

After this experience, I also noticed I had to re-add almost all the other sheets as well for some reason so they updated with the new Accounts data. Overall, I absolutely love this new Foundations Template after using Tiller for almost a year!

At this time, as you have observed, the Tiller Labs add-on update & restore capability inserts and replaces sheets but does not have the capability to migrate user-entered data. The approach you used, @Nakeva, of duplicating the sheet and the migrating key data manually is a good workflow given the limitations. (For many of the solutions that analyze and display data, migration shouldn’t be an issue since the data is stored upstream in core feeds sheets.)

Our intent is that you shouldn’t have to re-add other solutions after an upgrade, but I have seen this new add-on struggle getting downstream sheets to refresh formula content— particularly with the INDIRECT() formula— when upstream sheets are replaced. In your case, the sheets flow like this:
Balance History --> Accounts – > Balances + Quick Insights
As we learn, we are working through updates to the formulas that will allow the upstream sheets to be replaced more seamlessly (i.e. without affecting downstream sheets).

I’m happy to hear that a) you found your way through these hurdles, and b) you appreciate the new tools and workflows.

Best,
Randy

1 Like

Weekly Trends sheet returning only 4 weeks of categories. Also, Weekly Trends sheet is missassigning transactions Weekly start of value.

From the new tiller foundations template using the tiller money feed, I have added the weekly trends sheet. I have had transactions that in the Transactions sheet have a date, month, and week of with a value of 09/01/19. In the Weekly Trends sheet, these are being assigned with a Date of 09/01/19 and a Week Start of 08/25/19.

I have attempted to increase the Max Rows to 500 to ensure all of the data is being fetched. I have deleted and re-added the sheet with the same results. I’ve attached screenshots of what I’m seeing in the sheet compared to the Transactions sheet.




57%20PM

Good catch, @xlengthy. I updated the template and bumped the version to 2.02.
Please use Tiller Labs to restore the Weekly Trends solution and let me know if the problem is resolved.

Thanks for your detailed bug-repro documentation! :slightly_smiling_face:
Randy

2 Likes

I updated to the new version and it’s working as expected.

You’re welcome for the details. I work in the help desk of software support so I’m pretty familiar with what the engineering team may need to address some unepxected behavior. I’m glad you found it useful and were able to get this corrected so quickly! I am loving the product and I can’t recommend it enough!

4 Likes

I’ve created a monthly budget solution in a new Google Sheet. The categories, transactions and monthly budget tabs were created. I put in the categories and the budgeted amounts and the budget tab is pulling the budget amounts correctly from the categories tab. However, actuals are not pulling in from the transactions. I have categorized all the transactions with correct categories but is still not populating.

Strange. So you’re using the Monthly Budget sheet and actuals are not flowing into the sheet, @Nadeem? Have you set the budget period in the upper right of the Monthly Budget to a range containing data? How were the Categories, Transactions and Monthly Budget sheets added to your spreadsheet? Via the Tiller Labs addon? From the Foundation template?

Hi @Nadeem,

If you’re using the budget with the rollover features, and you’re not seeing actuals, it could be an issue with the way your dates are formatted in the Transactions sheet. Are they 10/11/2019 or 10/11/19? If the latter, just change the date format to use the full year and that should do the trick.

Heather

@randy Yep. that is correct. I have picked a budget period that has data, and categories, transactions and monthly budget were added via the Tiller Labs addon. I’ve noticed that in the budget tab, the actuals are not pulling into columns T:W as show below. There is a formula in columns T15:V15. Perhaps the error is from there?

@heather I’ve also changed the date format as you mentioned but that hasn’t fixed the issue either.

the formulas are:
T15: =arrayformula(if(row(T15:T)=row(T$15),“Type”,if(isblank($V$15:$V),iferror(1/0),iferror(vlookup($V$15:$V,{$S$16:$S,$Q$16:$Q},2,false),"(hidden)"))))

U15: =arrayformula(if(row(U15:U)=row(U$15),“Group”,if(isblank($V$15:$V),iferror(1/0),iferror(vlookup($V$15:$V,{$S$16:$S,$R$16:$R},2,false),"(hidden)"))))

V15: =iferror(query(Transactions!A:Y,“SELECT “&K26&”,SUM(”&K27&") WHERE “&K26&” IS NOT NULL AND “&K25&” >= date ‘"&TEXT(K15,“yyyy-mm-dd”)&"’ AND “&K25&” < date ‘"&TEXT(eomonth(K15,0)+1,“yyyy-mm-dd”)&"’ GROUP BY “&K26&” LABEL SUM("&K27&") ‘Actuals’"))

Hmm, this is a little tricky to diagnose. Since you installed the budget from the Tiller Labs add-on (I think) try restoring it from the add-on under the Managed Solutions area and see if that helps.

Did you add any custom columns in your Categories sheet? Transactions sheet?

Heather

I recently updated the versions of some of my Tiller Labs Add-ons (Quick Insights, Accounts, & Monthly Budget) and now the dashboard that’s associated with the Tiller Business add-on is broken. The problem seems to be that all of the data fields from the dashboard sheets are stuck “loading.” I’ve tried restoring to a previous version but google sheets won’t let me and also tried logging out and back on again. Any idea what’s going on?

The most likely issue is that you’re using a version of the template that relies on a custom function called TILLER_PERIODPRESET() that is embedded in either the Tiller add-on or the Tiller Labs add-on. Is this function in the first row that says loading in column AD? If yes, is it possible one of the add-ons isn’t running in session you have the spreadsheet open in?

For performance and simplicity, we have stripped that custom function out of the current version of the template and replaced it with a long-ish in-cell formula.

On a related note, in my personal business template, that cell (in AD) is shifted over six cells in and is in column X. This suggests you’re either using an old version of the template or maybe made some modifications?

Curious to hear your answers.
Randy

Hi Randy,

The function in AD is in fact the TILLER_PERIODPRESET() function. Though it does seem to be working now for whatever reason.

To your point about the location of the formula in cell AD, I did add a few column in to add a couple of custom graphs but until now, that has had no bearing on the original graph functions.

It sounds like it was an issue with the TILLER_PERIODPRESET() custom function in the add-on not loading properly. Custom functions are cool— since one can use Apps Script to do heavy lifting— but they load slowly and don’t fill if the add-on or bound script isn’t present.

I’m glad to hear you’ve made some upgrades to the stock template to suit your needs… that’s what is so great about spreadsheets. There is no pressure to upgrade at all (because your customizations will be overwritten) but, if you continue to have issues with the custom function, you can consider using the Restore Dashboard workflow in the Tiller add-on to fetch the new version. I’d recommend making a copy of your version of sheet (in the spreadsheet) before it is overwritten.

Finally, we have flagged a bug in TILLER_PERIODPRESET(). It can be off by a day or two due to timezone issues. Hopefully I’ll get that fixed in the next week or so.

Best,
Randy

It seems I spoke too soon. The errors I mentioned previously are resolved. However, now there is no account data listed in B:I. Looking through the formulas used in those columns, it seems that the problem lies somewhere within AD1:AN7. But, I don’t know enough about the formulas used in those cells to trace the problem. I suspect the issue is somewhere in AK1:AN7 but the other cells are mentioned within that block so I can’t discount the possibility of an error there.

If it’s helpful, I can set the page to show formulas to help further diagnose the problems.

Thoughts?

ETA: Solution found here:
https://community.tillerhq.com/t/accounts-sheet-issue-downstream-solutions-broken-after-upgrading-sheet/782/4