How can I set 'Fill Sheets' to automatically run each day?

I appreciate the Tiller Daily Update emails, but I would like to receive a daily summary with a different set of information about new transactions. I am using Google Apps Script to write a script to send me a daily summary of only uncategorized transactions and a few other bits of customized data. The problem is each time I want Tiller to download new transactions, I have to open my Tiller worksheet and manually run the ‘Fill Sheets’ tool from the Tiller Money Feeds add-on.

It would be great if there was some way to have the Fill Sheets tool automatically run each day at a certain time. Is such functionality currently available? If it’s not an available feature of the Tiller Money Feeds add-on, is there anyway to access the underlying script of the Tiller Money Feeds add-on, so that I could trigger the Fill Sheets tool programmatically?

I really appreciate the ‘open’ nature of Tiller. I see in the Tiller documentation there is a high value for making the functionality as transparent as possible. For example, people who contribute templates, workflows and tools are encouraged (as much as possible) to use Google Sheets functions, which are more accessible to end users, rather than Google Apps Scripts, which are not as accessible. In that spirit of openness, it would be nice if users had (at least some) access to the scripts which run the Tiller Money Feeds add-on, so that users can more easily access features which are only available through scripting. I think such access would allow me to run the Fill Sheets tool automatically as I would like to do.

1 Like

There is an option for this, but it’s been unreliable for me. In your “Extensions” menu, open “Tiller Money Feeds” and select “Launch”. Go to “Settings” and you’ll find “Auto Fill”. Turn it on and it should do what you want. One catch that @heather explained recently is that you need to do a ‘manual’ Fill every week or two (I can’t find the post at the moment) for the setting to stick. In practice, mine seems to turn off even if I do that, so I’ve gotten used to always doing manual fills, which works OK for me as I don’t subscribe to the email reports.

Thanks @jpfieber for making me aware of the Auto Fill feature. I waited a few days to respond, because I wanted to test the feature first.

Here is my sequence of events:

Time Action Result
Monday afternoon Enabled Auto Fill
Tuesday morning Opened Tiller No new transactions
Immediately afterward Manually ran Fill Sheets New transactions downloaded
Thursday morning Opened Tiller No new transactions
Immediately afterward Manually ran Fill Sheets New transactions downloaded

Auto Fill documentation says it checks for new transactions each evening at 2:00 AM. It could be on Tuesday morning and this morning that my bank had posted new transactions after 2:00 AM. However, there were almost 48 hours for new transactions to accumulate before Auto Fill ran last night. Some new transactions should have posted during that window of time. I noted in your post you seem to have also found Auto Fill to be unreliable. I will continue to test the feature. Unfortunately, at this point it seems not to work.

The documentation mentions 2-factor authentication as the only factor which could disrupt Auto Fill. I don’t have 2-factor authentication on my accounts.

Can someone help me get Auto Fill working? Or, can Tiller provide another way to programmatically trigger a download of transactions, as I described in my original post?

After creating my previous post, I noticed a relevant new thread on the Help board. In Sheets not updating automatically and not receiving daily email transactions @heather explains the “need to launch the add-on at least once every 14 days” in order to keep Auto Fill enabled. I assumed this would not be an issue for me, since I had just enabled Auto Fill a few days ago. However, after reading Heather’s post, I checked my settings and Auto Fill was disabled.

@heather, thank you for engaging here on the thread to help users figure this out. Can you help me understand what may have caused Auto Fill to be disabled, when I enabled it only a few days ago? Thanks.

This is not the only factor that can disrupt Auto Fill. Some institutions require you to manually refresh even if you don’t have 2FA enabled because the auto refresh has been disabled for the institution. This is controlled by our data provider and the institution. More on that here.

If you open your Google Sheet and it doesn’t automatically start filling upon launch that means the Auto Fill is not actually toggled on. Double check the Settings to make sure it’s still on.

The Auto Fill setting does 2 things:

  1. It runs around 2AM to fill any new data available in our databases into your spreadsheet. If there is no new data it doesn’t have anything to fill.
  2. It starts a fill when you launch Tiller Money Feeds from the Extensions menu (some have expressed dissatisfaction with this part of the feature because they have to wait for the fill to finish before they can do other things in the add-on (e.g. run AutoCat)

If that 2nd action is not happening then AutoFill is not actually on.

You have to turn Auto Fill on in each sheet. This isn’t a global user setting, it’s a sheet by sheet setting.

If you get logged out of Tiller either intentionally or automatically due to inactivity (the period should be 14 days of inactivity) then the Auto Fill gets toggled off in all spreadsheets where it was previously turned on.

Let me know if that doesn’t help.

So is it correct to say that if EVERY connected sheet and sidebar isn’t opened at least every 14 days, then every sheet with with the option toggled on will be toggled off?