I unlinked an account but it still shows up in "Accounts"


I unconnected an account to one of my sheets but it still shows up in my Accounts and Balance tabs. None of the transactions are actually downloaded, and I can fix the situation by hiding the account on the Accounts tab, and it’ll disappear from Balance.

But is there a better way?


Deleting the account from the tiller console will delete it only from new data fills. All data from that connection previously downloaded will remain in your sheet unless you would like to delete it otherwise.

1 Like

I might’ve said the wrong word. I didn’t remove the connection from my Tiller console, I still have the connection for another spreadsheet.

I meant for that spreadsheet I unconnected the account.

Is it still the same result?

Ahh yes, it would in fact be the same result but still available in other sheets as selected.

This i believe would be called unlinking the account from a particular spreadsheet.

@th5418 I’ve noticed this also. I think it’s a bug and is happening somehow in the way the Accounts tab is set up if you look at the hidden cells to the right. What is interesting to me is that the “Last Update” column seems to refer to the last time that particular account was updated in this sheet – even if you have since disconnected that account from feeding that sheet and deleted out the old data (and the account is still connected in Tiller and fully up to date and feeding another sheet).

I think this is a bug that hopefully the Tiller team can take a look at. I’ve tried restoring both the Accounts and Balances sheets to try to reset them and remove the issue, but that doesn’t help (and wouldn’t be a great solution anyway as you lose your custom categorization on the Accounts sheet when you restore it). @randy – tagging you in case you want to take a look at this bug!

@Caroleen that date is pulling from the balance history sheet. So it will still populate as long as there are even a single entry there for a particular account in particular it is looking at the unique account id. So if you verify that all entries have been removed from balance history and it is still saying that then it is possible to have a bug.