Importing Mint via multiple CSVs and hit limit on lines? Stuck

Brand new to Tiller but have 10 years of data in Mint
I tried importing the full 3.3MB CSV file but that failed
Found a hint to split up so used the URL trick to get transactions for 2 year spans (about 2,400 transactions)
That worked well until 2017. When I went to import the next CSV using the Tiller Community Solutions Import CSV Line Items, it shows 2,443 transactions with a net transaction amount and dates but the Adding to Transactions sheet just has the blue dots going back and forth.
I have waited far longer than any other imports.
If I refresh the page, the Import CSV Line Items disappears but the transactions do not appear in Tiller.
Scrolling to my first transaction shows 16,346 lines (and 14 columns)
Appreciate any help

Sorry to hear, @hektoryash.

If workflows run longer than ~5 minutes, the add-on has crashed. In the crash logs, I can see SyntaxError: Unexpected end of file. (though I’m not sure this is your import). Is there maybe something odd about what is at the bottom of the file?

A couple things you might try:

  1. Import your split CSVs into a new Google Sheet, export them as CSVs, and hope they are clean enough to import using the CSV Import workflow in Tiller Community Solutions.
  2. Import into a new sheet in Google Sheets then match up the data manually to your Transactions sheet— e.g. match the column order, normalize charge polarity, etc— and then copy paste.

If it were me and the add-on weren’t working, I’d just do the latter. It’s a little scarier, but you’ll be through it in 5 minutes.


Looks like it is a single file/span as I went to 2019-2021 and that pulled in okay

So, you’ve moved all your transactions over, @hektoryash?