PayPal downloads

I still get the following message for PayPal at
“We’re unable to refresh your account at this time. Please try again later.”

Same result when re-entering my credentials.

Ultimately I’d like to stay with Tiller as the concept of an auto-updating Google Sheet appeals to me, but it’s not worth it if I have to manually add transactions. I just wish we could get a real answer from someone as to what’s going on, rather than ETA that keeps getting postponed. It’d be one thing for them to say it will be fixed in a month, then a month later it gets fixed. They keep saying it will be next week or the week after, then when that date comes, it’s stretched out another week or two. Just tell us what’s going on and whether we can expect a fix, EVER. It’s not as though it can’t be fixed, because other companies (e.g. Monarch) are not having any issues with PayPal at this time (over Plaid).

Well, something changed between yesterday and today. I just was able to sync again without any problem after not being able to do so for a month. I can’t explain why it’s working for me (and at least one other person), but not other people. But, hopefully, it’ll be working for everybody soon.

It worked for me today as well!

Happy that some of you can now Refresh PayPal. I just tried and same–old, same-old. Takes several minutes to secure login and several more “getting your data.” It then it pukes with “Requested data is unavailable at Paypal Business”.

I wonder if the difference is between personal and business accounts. My account that is now working is a personal account.

1 Like

PayPal still does not work for me on Tiller. I have a personal PayPal account.

Weird. What kind of MFA do you use? I get a code off an authenticator app. Just trying to figure out what could be different about your account. Sorry that it’s still not working for you.

I don’t use MFA currently. Maybe I should, though it would be ironic if adding more security were to allow Tiller/Yodlee in though. I wonder what the other person or two who can get on are using MFA-wise (or not).

Yeah, might be worth a try. Clearly, PayPal isn’t making this easy. If you report a broken bank connection to Tiller, they always ask what kind of MFA you use. That leads me to think that it’s a consequential variable in figuring these things out.

Just for info. It works for me. I have a personal account.
I was pretty sure that 2FA was enabled via text, but when I checked it was off. Seems that 2FA via text is not available at PayPal anymore, only with an Authenticator app.

I tried adding 2FA at PayPal (via Google Authenticator) to no avail (at Tiller).

The reason Tiller support would ask about 2FA is because the aggregator (Yodlee) may need to prompt you for a 2FA code if you use 2FA, in order for it to work, and it might not work if it is for some reason unable to do so. It’s more difficult to get things to work WITH 2FA than without. Presumably, with your use of 2FA, you get asked by Tiller (when connecting to PayPal) for your PayPal 2FA code?

In any case, I’ve switched it back to no-2FA just so that that is removed from the equation if/when this is finally resolved. For what it’s worth, PayPal is still listed on the institution alerts as down.

What does it say beside PayPal “last refreshed…” at ?

Hmm. Puzzling. I refreshed and filled PayPal this morning. On the console, it is green and says last refreshed six hours ago. In my sheets, I have an updated balance history for PayPal from when I filled after refreshing. And, yes, every time I refresh PayPal I have to provide the code from the authenticator app. This is how it was for me before the recent outage.

Paypal has been removed from the Institutional Alerts sheet for several days now, but my PayPal business account is still not importing transactions. It connects just fine, and shows the current balance, but the latest transaction imported is from about 7 weeks ago. Any suggestions?

Just want to add my 2 cents here as my issue connecting was resolved on 3/5/2024 but some issues still seemingly remain.

For context, I do not sync PayPal activity other than from my PayPal Mastercard. If you have a PayPal Mastercard it shows up as a second item underneath PayPal in the Tiller console. I removed the PayPal “account” (underneath the PayPal institution) and kept only the PayPal Mastercard (account). This way I only pick up my PayPal credit card transactions, and not all the transactions I pay over PayPal (with various other credit cards), given that those other cards have their own feeds from their respective institutions (not the PayPal institution). The PayPal credit card transactions can only be imported if you connect the PayPal institution.

Not long ago, for a period of about two months, PayPal would not refresh through Tiller at all. The Tiller console would show some error in connecting. On 3/5/2024, the connection error resolved, however only a subset of my PayPal credit card transactions were imported. I noticed the last transaction imported into Tiller was that shown on my last credit card statement; in other words, only transactions on my “current statement” – the in-progress statement cycle – were not imported. I was a little concerned, given these transactions on the “current statement” would always import as soon as they were posted previously (I did not have to wait for the statement cycle to end), but I chucked that up to some change in the API where perhaps they only import transactions on finalized statements. Which is fine, not ideal, but fine.

However, my next statement ended yesterday, and though Tiller is able to connect with PayPal today, all it does is update my PayPal credit card balance, it does not import the PayPal credit card’s transactions. The console says PayPal was updated a minute ago, and the balance is up to date, but I don’t have any transactions from my last statement. Only transactions from the statement prior, which were last added 3/5/2024, when the connection issue first resolved.

My hope is that there is just some weird delay and that the transactions will import soon, however with PayPal off of the “institutions with problems” list, it is disconcerting.

1 Like

It looks like the PayPal Mastercard is administered by Synchrony. Synchrony seems to have an outage at the moment. I wonder if that’s related to the issues you’re having. That is, maybe the issue is more with Synchrony, not PayPal. I know that isn’t all that helpful, but just an observation and thought on what might need fixing.

My account also has a Paypal Mastercard attached, but its rarely used compared to the paypal account itself, which sends and receives many payments every day.

Looks like those Synchrony alerts originated prior to March 5 though and I was able to pull transactions on that date.

Interestingly enough, when I refreshed today, it did pull the transactions from the last statement. Maybe there’s a one day lag between the end of the statement cycle and the API getting access to the card’s transactions. The balance updates correctly, in between statement cycles. Not too big a deal waiting a month and categorizing thereafter. Was just concerned it was still amiss in some way, but this I can deal with.

1 Like

Jan 20 to March 20, Celebrating two solid months of no Paypal transactions imported—with no fix in sight :tada:

Add me to the list of users whose PayPal business account transactions have stopped coming into Tiller.

It was such a nice thing when they did (for the short while when the connection with PayPal got fixed).

@Tiller, any info?

I’ve been involved with the ongoing PayPal situation. It was seemingly resolved in March. A Tiller update included my PayPal account and all back transactions that I had manually installed due to the issue with PayPal. Since then, my PayPal account balance updates regularly, but I have not had any of my PayPal transactions download to Tiller and subsequently upload to my Excel Transactions spreadsheet. Is anyone else experiencing this?