Split Transaction workflow question when viewing filtered transactions

I am filtering my transaction sheet to find the few items I need to split. When I then go to “Split Transaction” it often shows a totally different transaction (that is not even in the filtered rows) to split. What I end up having to do is note the row number and access it once I unfilter (and it turns out the row number is off by a few).

I’ve never had that happen, but I don’t think I’m usually in a filtered view when I do splits. I just tried that (using a filtered view), and it still pulled up the correct transaction for me (tried half a dozen different transactions).

One oddity I just noticed though is that the date shown in the sidebar for the transaction it’s going to split always comes up 1 day early. The spits themselves turn out with the correct date though. Is that just me?

Not sure about the date, but for a handful of transactions, it would pull up the correct information. It could be something with the filtering, since when I filter, I’m told row 654 is what I’m looking at, but when I turn off filtering, 654 is something different, which shouldn’t happen.

My experience with Google Sheets has led me to avoid using filters and instead use the slicer function. Slicer is found in the data menu. I believe that it filters only your view of the data without manipulating the actual data. It may work better with the “Split Transaction” process. Worth a try IMO.


Thank you! Slicing seems to do the trick.