Spreadsheet not working, “Exceeded Maximum Execution Time”

Starting a new thread since the thread I replied in had a resolution that did not work for me. I am unable to get my spreadsheet to update at least in the last couple of days. Upon launching in Google Sheets, the progress bar at the top right will start progressing and the ultimately stop at about the 90-95% mark and not finish. If I try to launch the side bar, a “Working” popup appears at the bottom and never goes away and the side bar never loads. After a while, a red bar that says “Exceeded Maximum Execution Time” will appear, but still no side bar.

I tried signing out and signing back in, which caused the side bar to appear for sign in, but then after sign in, I click the “Get Started” button, which does nothing until the red “Exceeded Maximum Execution Time” appears again.

I am signed in on the correct Google profile and am experiencing this in both Firefox and Chrome.

Thanks for sharing in a separate thread @ryanfowler88.

So just to clarify, you’re using a dedicated Google Chrome browser profile? I.e. you’re not signed in to other users in the browser?

Hi @heather, correct. I actually downloaded Chrome yesterday to see if it would fix the issue as I normally use Firefox. I just checked and I only have my main account signed into Chrome, which is the one that is my Tiller account.

Also, just tried incognito mode and got the same issue.

@ryanfowler88,

Can you let me know how many tabs you have in your sheet? My guess is that the progress bar is choking on complex formulas/calculations/dashboards in your sheet and that is hogging up the execution time that Google has to use so when you open the sidebar there’s no time left.

Some code changes may have exacerbated this issue, but need to understand what type of data set/sheets you’re working with.

Feel free to write to support@tillerhq.com about this issue directly if you prefer not to share these details via a public forum.

@heather ,

I have 15:

  • Insights
  • Monthly Analysis
  • Monthly Budget
  • Categories
  • Transactions
  • Balance History (Greyed Out)
  • AutoCat
  • Balances
  • Net Worth
  • Accounts
  • Yearly Budget
  • Help
  • Savings Budget
  • Account Filter
  • Budget Journal

As a test, I removed any of the above that were Community Solutions. This actually allowed the progress bar at the top right to finish, but I still cannot open the Tiller Money Feeds sidebar. I created a new Tiller Foundation spreadsheet just now and everything works just fine, with all transactions importing and I can open the side bar on this new one. It seems like my original spreadsheet might have gotten corrupted or something?

@ryanfowler88,

It’s possible yes that edits to it somehow caused it to get stuck when trying to open the add-on. I’m not totally sure, I’ve seen this rarely in the past, but I don’t recall whether the error you’re seeing was involved and I do know that the changes with the upgraded API could be also causing that error to pop up.

If you let the progress bar in the top right finish and then wait a minute or so, are you able to open the add-on? Does it give you the same Exceeded Max time" error or is it doing something different now?

Hi @heather,

Sorry for the delay in getting back to you. The old spreadsheet that was giving me the issues does seem to be working fine now after leaving it alone for a week. It successfully finishes the progress bar, the side bar opens, and the contents update correctly. Not really sure if this gives an idea of what the root cause was, but at least everything is working! Thanks for the help!

1 Like