Tiller Splitter Tool Performance Issues

Has anybody else been having problems with this tool? I have been having issues for at least a couple of months. It times out on me and then I need to finish the split manually. The other day it just stopped midstream. How do I fix this tool?

We haven’t changed that add-on in a while, @blake… so, failures would either be:

  • A change by Google to the API or execution environment that is causing old code to fail
  • An unusual use case by you

Are you seeing failures across the board or just in certain instances?

Randy

1 Like

I have not had success with a paycheck in the last 2-3 months. It works completely correct about 25% of the time. Can I uninstall then reinstall?

You can try that, @Blake, but I’m skeptical it will help. (Reloading the browser tab also reloads all the add-ons— e.g. in case there are updates to the scripts).

Unfortunately, there is likely something in the add-on that needs to be updated to address your use case. I will tag @heather so it is noted in the bug-tracker.

Randy

I mean uninstall and reinstall the splitter tool which I did.

Hi @Blake,

Can you let me know a bit more about the circumstances when it usually times out? Are you trying to split a transaction more than 3 ways? Is there a specific sheet where it works and another where it doesn’t work?

I have had no issues running the splitter so I’m thinking it’s something to do with your environment specifically.

I’d recommend always trying in a dedicated browser profile for your Tiller-subscribed gmail account if you aren’t already doing that. Sometimes being logged in to multiple Google accounts in a single browser can cause issues with add-ons.

If you reach out via support@tillerhq.com we can troubleshoot in more depth. It’s important to us to figure out what’s going wrong here so we can document a work around and ultimately fix the tool.

Heather

Appreciate it. As I mentioned, I uninstalled and reinstalled the tool. That process went slow and clunky but it finally got there. Then I did a three way split and it worked. My paycheck splits have about ten splits. I have had issues with the tool in all of my sheets. I will monitor it and let the help desk know if I continue to have issues. Not sure what you mean by your third paragraph. I only have one google account open at a time but that one google account has four tiller sheets and I usually have more than one tiller sheet open at a time in the same chrome browser. Please advise. Thanks, Blake

I tried using the splitter today and when I split a transaction it causes an error in the Groups column of my transactions tab? 35%20PM|366x500

I think I have seen that error before, @keenan.burkepitts. Is it possible you have an ARRAYFORMULA() populating down out of the header (presumably column G in cell G1)? If static text is inserted into a column that is populating with an ARRAYFORMULA() sometimes you see this kind of error. The simplest solution is to remove the formula in G1 or to just delete the value written by the splitter scripts into G17 and allow the ARRAYFORMULA() to populate the cell instead.

Hope this helps.
Randy